Problems with Openoffice-2.0.0

Gerard Beekmans gerard at linuxfromscratch.org
Sat Nov 19 20:32:22 PST 2005


DJ Lucas wrote:
>> alex at portlfs:~$ soffice -display 0:0

That one isn't working for me:
gerard at garion:~$ /opt/openoffice.org2.0/program/soffice -display 0:0
_X11TransSocketINETConnect() can't get address for 0:6000: Name or 
service not known
_X11TransSocketINETConnect() can't get address for 0:6000: Name or 
service not known
/opt/openoffice.org2.0/program/soffice.bin X11 error: Can't open 
display: 0:0

Since $DISPLAY is set to :0.0 I tried that, but then the assertion 
problem comes up again.


gerard at garion:~$ /opt/openoffice.org2.0/program/soffice -display :0.0
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: 
_dl_next_tls_modid: Assertion `result <= 
_rtld_local._dl_tls_max_dtv_idx' failed!


> I'd hold off for now.  Gerard is seeing the same issue with the 
> precompiled version.  Can I suggest you try the following real quick and 
> see if it resolves the issue?
> 
> 'LD_ASSUME_KERNEL=2.4.0 swriter'
> 
> If that works, then we are in the ballpark.  Gerard, if you are watching 
> this thread, the same may apply.

No go on that one:

gerard at garion:~$ LD_ASSUME_KERNEL=2.4.0 
/opt/openoffice.org2.0/program/soffice
/bin/sh: error while loading shared libraries: libdl.so.2: cannot open 
shared object file: No such file or directory

In fact, I can't run any program when LD_ASSUME_KERNEL is set to 2.4.0. 
For instance running /bin/ls:

gerard at garion:~$ LD_ASSUME_KERNEL=2.4.0 ls
ls: error while loading shared libraries: librt.so.1: cannot open shared 
object file: No such file or directory




-- 
Gerard Beekmans

/* If Linux doesn't have the solution, you have the wrong problem */




More information about the blfs-support mailing list