Unknown storage size of cr, gnome-keyring-0.8 to 6.3 blfs

Bruce Dubbs bruce.dubbs at gmail.com
Sat Nov 28 19:57:20 PST 2009

LinuxPuertoMontt wrote:
> hello friends, i'm alfredo and i'm new in the mailing list. I'm working on a
> blf system, i had a little problem with the packages, but that was solved,
> anyway it is imposible to me to build gnome-keyring-0.8.
> i make the ./configure this way:
> "./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
>             --libexecdir=$(pkg-config \
>                 --variable=prefix ORBit-2.0)/lib/gnome-keyring"
> i get this error when i do make:
> make[2]: se ingresa al directorio
> '/home/mud_adict/pakages/gnoe-keyring-0.8.1' if gcc -DHAVE_CONFIG_H -I. -I.
> -DPREFIX=\""/optgnome-2.18.3"\" -DBINDIR=\""/opt/gnome-2.18.3/bin"\"
> -DLIBEXECDIR=\""/opt/gnome-2.18.3/lib/gnome-keyring"\"
> -DGNOMELOCALEDIR=\""/opt/gnome-2.18.3/share/locae"\" -I. -I.
> -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
> -I/usr//include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
> -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12
> -I/usr/loca/include  -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
> -g -02 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include   -MT
> gnome-keyring-daemon-io.o -MD -MP -MF ".deps/gnome-keyring-daemon-io.Tpo"\
>  -c -o gnome-keyring-daemon-io.o 'test -f 'gnome-keyring-daemon-io.c' ||
> echo './''gnome-keyring-daemon-io.c; \
> then mv -f ".deps/gnome-keyring-daemon-io.Tpo"
> ".deps/gnome-keyring-daemon-io.Po";\
>  else rm -f ".deps/gnome-keyring-daemon-io.Tpo"; exit 1; \
> fi
> gnome-keyring-daemon-io.c: En la función read_unic_socket_credetials:
> gnome-keyring-daemon-io.c:184: error: no se conoce el tamaño de
> almacenamiento de cr

My input may be of limited use since I don't build gnome but sometimes 
it's helpful to look at the command.  I pasted the above into vim and 
formatted it to be readable:

       -MT gnome-keyring-daemon-io.o
       -MF ".deps/gnome-keyring-daemon-io.Tpo"\
       -o gnome-keyring-daemon-io.o
       'test -f 'gnome-keyring-daemon-io.c'
       echo './''gnome-keyring-daemon-io.c; \

   mv -f ".deps/gnome-keyring-daemon-io.Tpo" 

   rm -f ".deps/gnome-keyring-daemon-io.Tpo"; exit 1; \

It may not be the error you are experiencing, but the line:


seems to be missing a slash after opt.

Since this comes from
   pkg-config --variable=prefix ORBit-2.0
it may be an error or it may just be a paste error into your email since
LIBEXECDIR seems to be right.

In any case, you might want to try:

cd /home/mud_adict/pakages/gnoe-keyring-0.8.1

     -I. \
     -DPREFIX=\""/opt/gnome-2.18.3"\" \
     -DBINDIR=\""/opt/gnome-2.18.3/bin"\" \
     -DLIBEXECDIR=\""/opt/gnome-2.18.3/lib/gnome-keyring"\" \
     -DGNOMELOCALEDIR=\""/opt/gnome-2.18.3/share/locae"\" \
     -I/usr/include/gtk-2.0 \
     -I/usr/lib/gtk-2.0/include \
     -I/usr/include/atk-1.0 \
     -I/usr//include/cairo \
     -I/usr/include/pango-1.0 \
     -I/usr/include/glib-2.0 \
     -I/usr/lib/glib-2.0/include \
     -I/usr/include/freetype2 \
     -I/usr/include/libpng12 \
     -I/usr/loca/include \
     -I/usr/include/glib-2.0 \
     -I/usr/lib/glib-2.0/include \
     -g \
     -02 \
     -I/usr/include/dbus-1.0 \
     -I/usr/lib/dbus-1.0/include \
     -MT gnome-keyring-daemon-io.o \
     -MD \
     -MP \
     -MF ".deps/gnome-keyring-daemon-io.Tpo"\ \
     -c \
     -o gnome-keyring-daemon-io.o \

Make sure there is no whitespace after any of the trailing backslashes. 
  You may get the same error, but this isolates things a bit.

If you do get the same error change the -c to -E and
   -o gnome-keyring-daemon-io.o
   -o gnome-keyring-daemon-io.E

This just runs the preprocessor to look at what is done after includes 
and macros are evaluated.  There may be a lot of blank lines in the -E 
file so to remove them for easier viewing, use:

  sed -i '/^$/d' gnome-keyring-daemon-io.E

or you may just want to:

  grep socket.h  gnome-keyring-daemon-io.E
  grep 'cr ' gnome-keyring-daemon-io.E

to see if you can spot anything.

   -- Bruce

More information about the blfs-support mailing list