Unable to bring up X windows

Jim McConville jhmc at xmission.com
Wed Oct 21 13:57:06 PDT 2009


On Wednesday 21 October 2009 12:33, Guy Dalziel wrote:
> On Wed, Oct 21, 2009 at 12:21:35PM -0600, Jim McConville wrote:
> > I have compiled the X Window system in accordance with the latest BLFS
> > svn and have  succesfully executed the command:  "X -retro -config
> > ~/xorg.conf" .
> >
> > When executing "startx .xinitrc" I get the typical black screen, followed
> > by a dimmly lit screen and a reversion back to the text screen.  This
> > screen displays the xterm commands and ends with:
> > "error setting MTRR (base = 0xe0000000, size = 0x0ff00000, type = 1)
> > Invalid argument (22) "
>
> Jim, what exactly are you trying to do? It sounds to me as if all you
> have in .xinitrc is a line to load up xterm, but the MTRR error
> shouldn't have anything to do with it not working. You need to make sure
> that all commands except the last one are backgrounded - as the last
> command becomes the process that's in control of the desktop.
>
> For example:
>
> xmodmap -e "pointer = 3 2 1" &
> xterm &
> fluxbox
>
> but if you were only loading up an xterm you would do this:
>
> xmodmap -e "pointer = 3 2 1" &
> xterm
>
> The xmodmap line is just there as an example, it's not necessary for
> your configuration. I hope that helps.

Guy,
I have attempted to bring up the X window system using the command:
"startx file"
for all of the attached files.  The results are the same as indicated above.

I suspect the problem has something to do with the embedded window manager. 
The Xwindow system is undergoing complete revision  and  dispite the fact 
that I tried to adhere to BLFS svn there is always a good probability that I 
made an error somewhere.

If the attached files are too large for the system, I can compress them into 
individual bz2 format.

Jim
-------------- next part --------------
startfluxbox
-------------- next part --------------
# .xinitrc-lesstif 10/7/06
 eval "exec /usr/lesstif/bin/mwm" 
# For better tracking use:
# eval "exec /usr/lesstif/bin/mwm" -debug >"$HOME"/.MWM-errors 2>&1
# See /usr/share/doc/lesstif-0.94.0/doc/INSTALL.html#bin_Linux

-------------- next part --------------
# Begin .xinitrc.twm
xterm	-g 80x40+0+0	&
xclock	-g 100x100-0+0	&
twm
# End

-------------- next part --------------
xfce-mcs-manager
xfwm4 --daemon
xftaskbar4 &
xfdesktop &
exec xfce4-panel
-------------- next part --------------
xmodmap -e "pointer = 3 2 1" &
xterm &
fluxbox

-------------- next part --------------
xmodmap -e "pointer = 3 2 1" &
xterm



More information about the blfs-support mailing list