youtube with gnash

Ken Moffat zarniwhoop73 at googlemail.com
Fri Oct 30 08:42:40 PDT 2009


Back in the summer, I had youtube working on almost everything I wanted to
watch, via the gnash plugin for firefox, and posted that:

 http://linuxfromscratch.org/pipermail/blfs-dev/2009-August/019791.html
(whoops! accidentally sent that to -dev instead of -support: bad Ken!)

Over the next weeks I played about with every from-source codec/audiolibrary
I could find, and also got my amp working again (a kernel issue!).  There were
still a few videos that didn't render, but I got sound (needed faad2
for the silent
films with dubbed-on projection noise) and things were good.

By the time I started to build my next system, gnome-2.28 was out (I'll offer
my experiences on that later) and various other upgrades, including a newer
version of gnash.  Gnash is now the last thing I build, and it took a very long
tiem before I got there.  Tried it, just a black box where the video should be.

Went back to tjhe old system to watch a video there - same result.  Something
at youtube has changed (again).  Found a note that a method of downloading
the videos (instead of just watching them) had broken in August, and another
contemporary note that a package in ubuntu needed to be updated to work
with changes at youtube.  But that's all I've found.

I'm now at the stage where a very few videos will render (found 4 so far),
and even some which were working for me in the early days (when less
than half worked) no longer play.

Noticed that fedora is using a gnash snapshot - found a slightly newer one
but the results were identical.

So, I'm open to suggestions (except those that begin "download from
adobe" - I want libre, not binary downloads).

Anybody else seeing this ?  Anybody using gnash and NOT seeing this
problem ?

ĸen
-- 
After tragedy, and farce, "OMG poneys!"



More information about the blfs-support mailing list