wicd dbus socket problem

Ken Moffat zarniwhoop at ntlworld.com
Fri Sep 3 17:17:16 PDT 2010


On Fri, Sep 03, 2010 at 05:56:59PM -0500, rhubarbpie at poetworld.net wrote:
> 
> Invoking wicd1.7.0 generates the following log file:
> 
> 2010/09/03 17:11:33 :: wicd is version 1.7.0 552
> 2010/09/03 17:11:33 :: Traceback (most recent call last):
> 2010/09/03 17:11:33 ::   File "/usr/share/wicd/daemon/wicd-daemon.py", line 
> 1839, in<module>
> 2010/09/03 17:11:33 ::     main(sys.argv)
> 2010/09/03 17:11:33 ::   File "/usr/share/wicd/daemon/wicd-daemon.py", line 
> 1801, in main
> 2010/09/03 17:11:33 ::     bus = dbus.SystemBus()
> 2010/09/03 17:11:33 ::   File 
> "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 202, in __new__
> 2010/09/03 17:11:33 ::     private=private)
> 2010/09/03 17:11:33 ::   File 
> "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 108, in __new__
> 2010/09/03 17:11:33 ::     bus = BusConnection.__new__(subclass, bus_type, 
> mainloop=mainloop)
> 2010/09/03 17:11:33 ::   File 
> "/usr/lib/python2.6/site-packages/dbus/bus.py", line 125, in __new__
> 2010/09/03 17:11:33 ::     bus = cls._new_for_bus(address_or_type, 
> mainloop=mainloop)
> 2010/09/03 17:11:33 :: dbus.exceptions.DBusException: 
> org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket 
> /var/run/dbus/system_bus_socket: No such file or directory
> 
> Is anyone running wicd?
> 
> 
> 

 Not me, never heard of it until now.  But I'm using 1.2.20 on my
current (old: 6.6) system and that socket exists.  Did you install
the dbus bootscript and start dbus ?  Are you using an older version
of dbus ?

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list