Python-2.7

Ken Moffat ken at linuxfromscratch.org
Tue Sep 7 10:52:53 PDT 2010


On Tue, Sep 07, 2010 at 06:19:22PM +0100, Andrew Benton wrote:
> 
> I see. It looks like the error is related to gobject-introspection-1.0.
> I can't find "bank-argument.c" in my buildlog, perhaps it's only 
> compiled if gobject-introspection is present?
> A similar section from my buildlog looks like this:
> 
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I../gobject 
> -I/usr/include/python2.7 -I/usr/include/python2.7 -pthread 
> -I/usr/include/glib-2.0 -g -O2 -Wall -fno-strict-aliasing -std=c9x -MT 
> testhelpermodule.lo -MD -MP -MF .deps/testhelpermodule.Tpo -c 
> testhelpermodule.c  -fPIC -DPIC -o .libs/testhelpermodule.o
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I../gobject 
> -I/usr/include/python2.7 -I/usr/include/python2.7 -pthread 
> -I/usr/include/glib-2.0 -g -O2 -Wall -fno-strict-aliasing -std=c9x -MT 
> test-unknown.lo -MD -MP -MF .deps/test-unknown.Tpo -c test-unknown.c 
> -fPIC -DPIC -o .libs/test-unknown.o
> mv -f .deps/test-thread.Tpo .deps/test-thread.Plo
> mv -f .deps/test-unknown.Tpo .deps/test-unknown.Plo
> mv -f .deps/testhelpermodule.Tpo .deps/testhelpermodule.Plo
> and so on...
> 
> It's academic now that you've installed gobject-introspection and 
> pygobject-2.21.5 but perhaps the build would succeed if you compiled 
> pygobject-2.20.0 before you install gobject-introspection-1.0?
> 
> Andy
> -- 
 That seems a plausible hypothesis.  I need introspection for
epiphany, so I build introspection as early as I can, so that all
the gnome/gtk packages can use it.  First time I added it, I had to
rebuild atk, gtk+, and probably others.

 Pygobject is just a "nice to have for gnumeric", so I'm in no rush
to build it [ once I can build firefox (icecat, but essentially the
same thing ] the system is usable enough to search for answers on
any later problems.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list