Network/internet problems

Bruce Dubbs bruce.dubbs at gmail.com
Fri Sep 10 09:08:21 PDT 2010


Timothy Rice wrote:
> Hi Bruce,
> 
>> You don't say what version of the kernel you are using or what network
> driver.  Until you get things set, I'd use a static IP just to eliminate
> one variable.
> 
> The base LFS is 6.5 with kernel 2.6.30.2.
> 
> 
>> If you connect directly to the network without the router, do you get
> the same problem?  You'd have to use dchp there though.
> 
> This is how I had it set up before I got the router. To double check
> everything still works, I put it back how it was, and yep no problems.
> 
> 
>> Are you using iptables at all?
> 
> I ran `iptables -S' and obtained:
> 
> -P INPUT DROP
> -P FORWARD DROP
> -P OUTPUT DROP
> -A INPUT -i lo -j ACCEPT
> -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
> -A OUTPUT -j ACCEPT
> 
> I can't remember whether these are default settings or whether I put these
> in myself...

I'm not familiar with an -S option.  Do you mean -L?

In any case, reset it to remove a variable:
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT

>> Is there any possibility that there is more than one system using the
> same IP address?
> 
> This occurred to me. I previously assigned 192.168.1.1 to eth1. When I
> first tried setting up the router from Ubuntu, I encountered problems due
> to this address conflict. However, I have done my best to ensure that
> these conflicts have been removed. Running `grep --recursive 192.168.1.1
> /etc' gives only one result,

Is the only system in the network your dektop.  That is, doe sit look 
like:  ISP <--> router <--> desktop

Is there anything else?

> /etc/sysconfig/network-devices/ifconfig.eth0/ipv4:GATEWAY=192.168.1.1
> 
> I believe this is correct for accessing the net through the router. If
> there was a settings conflict somewhere, I would expect the grep command
> to return more results than this.

That is right for the router with a static IP.  dhcp would reset it if 
if needed.  For a static address, you need

ONBOOT=yes
SERVICE=ipv4-static
IP=192.168.1.2
GATEWAY=192.168.1.1
PREFIX=24
BROADCAST=192.168.1.255

>> Install net-tools and give the results of 'ifconfig -a' and 'route -n'.
>>
>> You especially want to look for things like errors, collisions, etc
> 
> I ran these commands from within a chroot environment within Ubuntu.
> Ubuntu has (annoyingly) swapped eth0 and eth1, so keep that in mind when
> reviewing the following results:
> 
> ifconfig -a

> eth1      Link encap:Ethernet  HWaddr 00:0C:F1:FD:19:7C
>           inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:365 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:421 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:100
>           RX bytes:248519 (242.6 Kb)  TX bytes:61695 (60.2 Kb)

Not very much data.  Does it fail in chroot and not from the normal 
boot?  Are you mounting /sys and /dev into /mnt/lfs before going to chroot?

> route -n
> Kernel IP routing table
> Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
> 192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth1
> 169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth1
> 0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth1

That looks OK, but I don't know where 169.254.0.0 got set.  It's not a 
part of a standard LFS build.  Perhaps it was dhcp.  In any case, you 
don't need it.

The config looks OK, but you may want to try a later kernel.  Some 
kernels reported network driver bugs.  That was true for my HW, but my 
version of 2.6.30.2 works OK.

CONFIG_E1000E=y

 From lspci:
Intel Corporation 82567LM-3 Gigabit Network Connection

   -- Bruce



More information about the blfs-support mailing list