udev alsa pulse kde4.4.5

luxInteg lux-integ at btconnect.com
Tue Sep 14 05:47:41 PDT 2010


On Sunday 12 September 2010 01:43:00 luxInteg wrote:

> excerpt from
> ( http://www.pulseaudio.org/wiki/PerfectSetup)
> {
> There are three kind of distributions:
> 1) those who control access to the sound card by adding users to the
> "audio" group,
> 2) those who use HAL and ConsoleKit to dynamically give access to the
> currently "active" user, but allow overriding that using the "audio" group
> and 3) those who don't use the "audio" group at all, but rely solely on
> HAL+ConsoleKit to grant access to the sound card.

 

I updated udev to udev-162.  And  I can report some progress and some 
glitches.

PROGRESS:
--------
---a) the first login and logout  via kdm gives the  welcome and exit sounds 
consistently
---b)the  kde/~Multimedia dialog has  a dummy greyed-out icon and another as 
'Internal Audio analog stereo' -it odes not describe the manufacturer/partNo  
of the sound  ASIC
---c) aplay plays wav files in konsole  -as well as on the cli in/before/after 
startkde/kdm-logout


GLITCHES
-----------
---d) kde/sound is mute for all other logins and logouts  bar the first
---e) audio CDROMs do not play neither with KsCD nor Kaffeine for any logins

-----------------------------------------------------------------------------

It seems to be as I long suspected a problem with hal and ConsoleKit   
fiddling with 'sessions' 

Suggestions of a fix  for  reliable sound  on ALL KDE logins  and on playing 
CDROMs would be appreciated.



More information about the blfs-support mailing list