compile problems with multiple packages

Simon Geard delgarde at ihug.co.nz
Thu Oct 13 00:23:04 PDT 2011


On Wed, 2011-10-12 at 16:52 -0400, S. Martinez wrote:
> Partha and Andrew,
> 
> Thank you both for your suggestions.  For now I downgraded to
> make-3.81 and managed to install the packages.  I do believe that I'll
> explore upgrading to the latest packages as I gain more experience and
> knowledge.
> 
> I am curious though... Is the problem with make or the problem with
> the sources?  I find it odd that I get similar errors from different
> packages.  Perhaps it's just a coincidence?

Strictly speaking, it's the same bug in both packages, but one that
doesn't show up when built with earlier versions of Make.

With development tools like Make (or GCC), it's often the case that
newer versions become stricter about the inputs they accept - this is
because a tool that simply rejects invalid input is usually simpler to
maintain than one that tries to work out what was intended.

That's the case here - both packages contain the same (or similar) error
in their Makefiles, but Make 3.82 complains about that error and 3.81
doesn't.

Simon.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20111013/49f16097/attachment.sig>


More information about the blfs-support mailing list