[blfs-support] problem using BS or DEL key

Alexey Orishko alexey.orishko at gmail.com
Wed Dec 4 04:11:00 PST 2013


On Tue, Dec 3, 2013 at 10:53 PM, Ken Moffat <zarniwhoop at ntlworld.com> wrote:
> On Tue, Dec 03, 2013 at 08:29:42PM +0000, Ken Moffat wrote:
>>
>>  What are the locales (LC_ALL or similar) in BOTH systems ?
Neither has LC_ALL set

Ubuntu and LFS-7.4 had this set:
LANG=en_US.UTF-8

My old LFS-6.3 has
LANG=en_US.ISO-8859-1

>>  Using 'showkey' [ in a tty ], find the values for the Backspace and
>> Del keys - on a regular 102-key keyboard mine are 14 and 111 - then
>> use 'dumpkeys | less' to find what is output for those keys - mine
>> are 'Delete' and 'Remove' : for no-latin1 the latter is corrected in
>> the patch.  I _think_ ubuntu has versions of both those commands
>> (from console-tools), so you could compare them.
On all systems showkey output is:
BS - keycode  14 and DEL -keycode 111
dumpkeys has 'Delete' and 'Remove'

>  Also, check what you have in /etc/inputrc [ LFS section 7.14 ],
content is exactly as in the book

After deeper investigation I got really confused....
BS/DEL problem exists in en_US layout and appearing while I'm deleting
SPACE symbol with BS within a string like "kkkkk kkkk".

I've changed LANG to LANG=en_US.ISO-8859-1 and UNICODE=0 and
problem is still there, however on old LFS-6.3 everything works fine with
LANG=en_US.ISO-8859-1 and even with "loadkeys no-latin1".

Problem looks like described in BLFS Chapter 2. Important Information,
Locale Related Issues: "The Program Breaks Multibyte Characters or
Doesn't Count Character Cells Correctly"

Since issue is present even with US keyboard layout, I wonder if ALFS
build did something funny during build (or didn't do something right).

I've tried to rebuild kbd with a patch, but didn't help.

If I log via ssh everyhting looks ok. Is it because I use other pc
facilities in this case?

/alexey



More information about the blfs-support mailing list