[blfs-support] Troubles Building NSS-3.15.3 [Corrected Major Error]

Dan McGhee beesnees at grm.net
Fri Dec 6 10:00:30 PST 2013


On 12/06/2013 11:14 AM, Pierre Labastie wrote:
> Le 06/12/2013 18:12, Dan McGhee a écrit :
>> For some reason I was compiling NSS in my Ubuntu host system using the
>> chroot environment.  Pierre's reference to a parallel build, and since
>> I wasn't trying to do one, got me looking.
> Sorry if I was wrong: I read
>
> [Linux3.8_x86_64_glibc_PTH_64_OPT.OBJ/pk11cert.o] Error 2
>     1446  make[2]: *** Waiting for unfinished jobs....
>
> And I thought that "make" wouldn't have to wait for unfinished jobs if not doing a parallel build. Anyway, glad you found how to
> compile it.
Pierre, you weren't wrong.  What you read is correct.  But what I 
learned is that with the <uname> options used, when I tried to compile 
using 'chroot' in Ubuntu, NSS picked up on the 3.8.xxx kernel Ubuntu 
uses.  When I tried to compile in {,B}LFS the error changed to 
"Linux3.10_x86_64 <etc.>" but remained the same. Make would still exit 
with "waiting for unfinished jobs."  And the first culprit was always 
"can't make the file."  That lead me to the permissions angle.  That's 
why this whole thing was confusing.

Maybe someday, I'll have the time and energy to "slog through" the build 
process and try to find out why this happened.  Although I'm happy with 
the outcome, I don't like to build as root.

Dan




More information about the blfs-support mailing list