[blfs-support] Automounting

Dan McGhee beesnees at grm.net
Mon Dec 9 10:30:39 PST 2013


I discovered in my research that autofs needs discreetly identified 
mount points for removable devices.  This is great for unique devices 
like CD/DVD players, cameras and PDA's, but it's quite cumbersome for 
mass storage devices with multiple partitions on them.  As a result, I 
installed xfce4 and wanted to use udisks.  So far, I have not been able 
to get anything to automount using this combination.  Running 'udisksctl 
status' gives the following output with the first two lines repeating 
four times before the whole thing stops.

> (process:26376): GLib-GObject-WARNING **: invalid (NULL) pointer instance
>
> (process:26376): GLib-GObject-CRITICAL **: 
> g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE 
> (instance)' failed
>
> (process:26376): GLib-GObject-CRITICAL **: g_object_unref: assertion 
> 'G_IS_OBJECT (object)' failed
> Error connecting to the udisks daemon: Error calling 
> StartServiceByName for org.freedesktop.UDisks2: 
> GDBus.Error:org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The 
> permission of the setuid helper is not correct
When I plug my USB drive in, /var/log/daemon.log gives:
> dbus[644]: [system] Activated service 'org.freedesktop.UDisks2' 
> failed: The permission of the setuid helper is not correct
When I log out of xfce, I see the following messages--I don't know when 
they occur although I have plugged in and removed one of my USB drives a 
couple of times.  The first long line occurs with each final statement.  
I will include the long line and then the two statements in order of 
their appearance.

> GVFS--Remote Volume Monitor--Warning remote volume monitor with dbus 
> name org.gtk.Private.UDisks2VolumeMonitor is not supported
>      thunar-volman: Could not detect the volume corresponding to the 
> device
I have reviewed my install logs and as far as I can see all the 
permissions of what I have installed are correct.  I could have missed 
something, however.  Additionally, I don't know if there are any of the 
applications and daemons that need to be owned by root. I'm specifically 
thinking of Polkit.  Most of the files are owned by their package names 
for my Package Users system.

In any event, I do not know where to even start troubleshooting.  I 
tried looking at the different files, but I do not understand the 
syntax, esp Polkit rules.  I've looked in the Arch, Gentoo and Xfce 
wiki's and couldn't find anything that solved the situation.

I will really appreciate any help.

Thanks,
Dan






More information about the blfs-support mailing list