[blfs-support] Xorg: startx will not start

Hans P. flyerm2222 at gmx.de
Mon Dec 9 15:06:00 PST 2013


Hello,

My BLFS run in an Virtualbox environment, so i have installed the
Xorg-Cirrus-Driver and the Xorg-Vesa-Driver.

Accordingly, i have enabled the modules in the kernel.

So i have expanded the file /etc/sysconfig/modules:
cirrusfb
# Fallback
uvesafb

When I try to start 'startx', then i get following:

[  1815.751]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[  1815.755] X Protocol Version 11, Revision 0
[  1815.757] Build Operating System: Linux 3.10.10mylfs i686
[  1815.759] Current Operating System: Linux mylfs 3.10.10mylfs #1 SMP
Mon Dec 9 17:38:31 CET 2013 i686
[  1815.759] Kernel command line:
BOOT_IMAGE=/boot/vmlinuz-3.10.10-lfs-7.4 root=/dev/sda1 ro
[  1815.762] Build Date: 09 December 2013  03:13:52PM
[  1815.763] 
[  1815.765] Current version of pixman: 0.30.2
[  1815.767]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  1815.768] Markers: (--) probed, (**) from config file, (==) default
setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1815.777] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Dec  9
23:10:56 2013
[  1815.779] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1815.780] (==) No Layout section.  Using the first Screen section.
[  1815.780] (==) No screen section available. Using defaults.
[  1815.780] (**) |-->Screen "Default Screen Section" (0)
[  1815.780] (**) |   |-->Monitor "<default monitor>"
[  1815.780] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[  1815.781] (==) Automatically adding devices
[  1815.781] (==) Automatically enabling devices
[  1815.781] (==) Automatically adding GPU devices
[  1815.781] (==) FontPath set to:
    /usr/share/fonts/X11/misc/,
    /usr/share/fonts/X11/TTF/,
    /usr/share/fonts/X11/OTF/,
    /usr/share/fonts/X11/Type1/,
    /usr/share/fonts/X11/100dpi/,
    /usr/share/fonts/X11/75dpi/
[  1815.781] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1815.781] (II) The server relies on udev to provide the list of input
devices.
    If no devices become available, reconfigure udev or disable
AutoAddDevices.
[  1815.781] (II) Loader magic: 0x8254bc0
[  1815.781] (II) Module ABI versions:
[  1815.781]     X.Org ANSI C Emulation: 0.4
[  1815.781]     X.Org Video Driver: 14.1
[  1815.781]     X.Org XInput driver : 19.1
[  1815.781]     X.Org Server Extension : 7.0
[  1815.789] (--) PCI:*(0:0:2:0) 80ee:beef:0000:0000 rev 0, Mem @
0xe0000000/16777216
[  1815.789] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file
or directory)
[  1815.790] Initializing built-in extension Generic Event Extension
[  1815.791] Initializing built-in extension SHAPE
[  1815.793] Initializing built-in extension MIT-SHM
[  1815.795] Initializing built-in extension XInputExtension
[  1815.796] Initializing built-in extension XTEST
[  1815.798] Initializing built-in extension BIG-REQUESTS
[  1815.799] Initializing built-in extension SYNC
[  1815.800] Initializing built-in extension XKEYBOARD
[  1815.801] Initializing built-in extension XC-MISC
[  1815.802] Initializing built-in extension XINERAMA
[  1815.804] Initializing built-in extension XFIXES
[  1815.805] Initializing built-in extension RENDER
[  1815.806] Initializing built-in extension RANDR
[  1815.807] Initializing built-in extension COMPOSITE
[  1815.809] Initializing built-in extension DAMAGE
[  1815.810] Initializing built-in extension MIT-SCREEN-SAVER
[  1815.811] Initializing built-in extension DOUBLE-BUFFER
[  1815.813] Initializing built-in extension RECORD
[  1815.814] Initializing built-in extension DPMS
[  1815.816] Initializing built-in extension X-Resource
[  1815.817] Initializing built-in extension XVideo
[  1815.818] Initializing built-in extension XVideo-MotionCompensation
[  1815.820] Initializing built-in extension XFree86-VidModeExtension
[  1815.821] Initializing built-in extension XFree86-DGA
[  1815.822] Initializing built-in extension XFree86-DRI
[  1815.823] Initializing built-in extension DRI2
[  1815.823] (II) LoadModule: "glx"
[  1815.824] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1815.824] (II) Module glx: vendor="X.Org Foundation"
[  1815.824]     compiled for 1.14.3, module version = 1.0.0
[  1815.824]     ABI class: X.Org Server Extension, version 7.0
[  1815.824] (==) AIGLX enabled
[  1815.825] Loading extension GLX
[  1815.825] (==) Matched vboxvideo as autoconfigured driver 0
[  1815.825] (==) Matched vesa as autoconfigured driver 1
[  1815.825] (==) Matched modesetting as autoconfigured driver 2
[  1815.825] (==) Matched fbdev as autoconfigured driver 3
[  1815.825] (==) Assigned the driver to the xf86ConfigLayout
[  1815.825] (II) LoadModule: "vboxvideo"
[  1815.826] (WW) Warning, couldn't open module vboxvideo
[  1815.826] (II) UnloadModule: "vboxvideo"
[  1815.826] (II) Unloading vboxvideo
[  1815.826] (EE) Failed to load module "vboxvideo" (module does not
exist, 0)
[  1815.826] (II) LoadModule: "vesa"
[  1815.826] (WW) Warning, couldn't open module vesa
[  1815.826] (II) UnloadModule: "vesa"
[  1815.826] (II) Unloading vesa
[  1815.826] (EE) Failed to load module "vesa" (module does not exist, 0)
[  1815.826] (II) LoadModule: "modesetting"
[  1815.826] (WW) Warning, couldn't open module modesetting
[  1815.826] (II) UnloadModule: "modesetting"
[  1815.826] (II) Unloading modesetting
[  1815.827] (EE) Failed to load module "modesetting" (module does not
exist, 0)
[  1815.827] (II) LoadModule: "fbdev"
[  1815.827] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  1815.827] (II) Module fbdev: vendor="X.Org Foundation"
[  1815.827]     compiled for 1.14.3, module version = 0.4.3
[  1815.827]     Module class: X.Org Video Driver
[  1815.827]     ABI class: X.Org Video Driver, version 14.1
[  1815.827] (II) FBDEV: driver for framebuffer: fbdev
[  1815.827] (--) using VT number 7

[  1815.862] (II) Loading sub module "fbdevhw"
[  1815.862] (II) LoadModule: "fbdevhw"
[  1815.862] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  1815.862] (II) Module fbdevhw: vendor="X.Org Foundation"
[  1815.862]     compiled for 1.14.3, module version = 0.0.2
[  1815.862]     ABI class: X.Org Video Driver, version 14.1
[  1815.862] (EE) open /dev/fb0: No such file or directory
[  1815.862] (WW) Falling back to old probe method for fbdev
[  1815.862] (II) Loading sub module "fbdevhw"
[  1815.862] (II) LoadModule: "fbdevhw"
[  1815.863] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  1815.863] (II) Module fbdevhw: vendor="X.Org Foundation"
[  1815.863]     compiled for 1.14.3, module version = 0.0.2
[  1815.863]     ABI class: X.Org Video Driver, version 14.1
[  1815.863] (EE) open /dev/fb0: No such file or directory
[  1815.863] (EE) Screen 0 deleted because of no matching config section.
[  1815.863] (II) UnloadModule: "fbdev"
[  1815.863] (II) UnloadSubModule: "fbdevhw"
[  1815.863] (EE) Device(s) detected, but none match those in the config
file.
[  1815.863] (EE)
Fatal server error:
[  1815.863] (EE) no screens found(EE)
[  1815.867] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
 for help.
[  1815.867] (EE) Please also check the log file at
"/var/log/Xorg.0.log" for additional information.
[  1815.867] (EE)
[  1815.874] (EE) Server terminated with error (1). Closing log file.


Why the cirrus driver is not recognized? - Ufortunaly the
fallback-driver vesa will not work too.

I have follow the instruction, but apparently i forgot something?
Please help me.

best regards
	Rado



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20131210/c9b0e405/attachment.html>


More information about the blfs-support mailing list