[blfs-support] Samba Daemons smbd nmbd winbind Don't Start

Alan Feuerbacher alanf00 at comcast.net
Tue Dec 10 21:17:25 PST 2013


On 12/8/2013 9:12 AM, Igor Živkovic wrote:
 > On 12/08/2013 02:20 PM, Alan Feuerbacher wrote:
 >> Yeah, as Fernando mentioned, I meant "failed to start". Here's the
 >> message I get upon bootup:
 >>
 >> *****Starting nmbd... [FAIL]
 >> *****Starting smbd... [FAIL]
 >> *****Starting winbindd... [FAIL]
 >
 >
 > What is the output of 'nmbd -F -S' command?

nmbd -F -S gives:
########
nmbd version 4.1.2 started.
Copyright Andrew Tridgell and the Samba Team 1992-2013
error opening config file '/etc/samba/smb.conf'
########

 From that I went back and looked over the BLFS installation stuff for 
Samba again. Oops! I missed that the default file 
/etc/samba/smb.conf.default had to be copied over to smb.conf . I had 
edited the default file appropriately but not copied it to smb.conf . 
Now nmbd, smbd and winbindd start up OK.

On 12/8/2013 9:20 AM, Fernando de Oliveira wrote:
 >
 > That's all? No more messages such as "/run/samba not found" or something
 > else? The suggestion I gave you before could give the complete output to
 > post here: run, as root:
 >
 > /etc/rc.d/init.d/samba start

In the console, /etc/rc.d/init.d/samba start was giving:
#############
*****Starting nmbd... [FAIL]
*****Starting smbd... [FAIL]
#############

But now that I fixed the smb.conf file, it works.

Thanks guys!

Alan



More information about the blfs-support mailing list