[blfs-support] Polkit Actions

Dan McGhee beesnees at grm.net
Wed Dec 11 15:02:44 PST 2013


Something happened in my "copy and paste" skills. This is how 
/usr/share/polkit-1/actions/org.freedesktop.policykit.pkexec.run-gparted.policy 
should actually look (the first line in the previous post shouldn't be 
there):

> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE policyconfig PUBLIC
> "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
> "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
> <policyconfig>
>
> <action id="org.freedesktop.policykit.pkexec.run-gparted">
> <description>Run GParted</description>
> <message>Authentication is required to run GParted</message>
> <defaults>
> <allow_any>no</allow_any>
> <allow_inactive>no</allow_inactive>
> <allow_active>auth_admin_keep</allow_active>
> </defaults>
> <annotate 
> key="org.freedesktop.policykit.exec.path">/usr/sbin/gparted</annotate>
> <annotate key="org.freedesktop.policykit.exec.allow_gui">TRUE</annotate>
> </action>
>
> </policyconfig>
Sorry for the noise.

Dan





More information about the blfs-support mailing list