[blfs-support] JSON-C fails to build

Pierre Labastie pierre.labastie at neuf.fr
Sat Dec 21 08:47:05 PST 2013


Le 21/12/2013 16:54, Dan McGhee a écrit :
> On 12/21/2013 01:40 AM, Chris Staub wrote:
>> I don't normally use json-c, but as I use package users myself I thought
>> I'd try it. I got exactly the same build failure when I used "-j4" with
>> make, and BLFS does say that this package does not support parallel
>> builds. It worked fine once I removed the -j. If it worked as root it's
>> probably just because you don't have MAKEFLAGS or something defined as root.
> This happened again for me with cdparanoia, which also, as the book 
> says, does not support a parallel build. I'm not sure how to set, change 
> or remove these flags.
> 
> Dan
> 
The -j flag for make is either set on the command line (takes precedence) or
in MAKEFLAGS.

Try "echo $MAKEFLAGS", to see what is in there. If it is empty, well, this
is something else. Do you use some kinf of cache (say config.site or so)?
MAKEFLAGS is maybe defined there.

OTOH, it is always possible to replace "make" with "make -j1", whether in
scripts or on the command line.

Regards
Pierre



More information about the blfs-support mailing list