[blfs-support] Audio--and other things[SOLVED]

Dan McGhee beesnees at grm.net
Sat Dec 21 18:28:27 PST 2013


On 12/21/2013 05:11 PM, Dan McGhee wrote:
> ...I now have audio and can play files
> and CD's.  However, the sound is weak and thready.
>
> This is the point at which Beats Audio comes in.  ALSA apparently
> assumes a "default" use of laptop speakers, and this "default" is not
> true with the Beats Audio system installed.  And, as a result, the sound
> is "weak and thready."  I don't know if any other laptops have it, but
> HP laptops do.  This situation can be "fixed" by changing the "pin out"
> in the "snd_hda_intel" driver.  There is an application called
> "hda_jack_retask" that can do it.  To date, I have not been successful
> in getting the changes applied.
>
> ...I believe that "hda_jack_retask" depends on PulseAudio because when I ran
> it and tried to apply the changes I got this message:
>
>> Failed to create file /root/.pulse/client.conf/<alpha-numeric name>
This is quite embarrassing. I had not installed alsa-tools. Originally, 
I went to the section "Short Descriptions" and saw that I didn't need 
any of what was listed. "hdajackretask" was not there. (hint, hint). As 
I was "googling" to try to solve the situation, one of the "hits" was 
the BLFS book for alsa-tools. So, I built only "hdajackretask" and tried 
it out. It worked. My sound is not "weak and thready" anymore. I could 
use more volume, but it's wonderful in headphones.

At first I still got the error message above, but discovered that 
hdajackretask's trying to write to .pulse/client.conf was "fixed 
upstream." So I created a symlink from ~/.pulse to ~/.config/pulse. 
Worked like a charm. Because of my previous failures, I was running the 
application as root. That's why it tried to write to root's home 
directory. I got my success as an unprivileged user--me.

Yes, hdajackretask is dependent on PulseAudio.
> I think xfce4 starts the PulseAudio daemon, but I don't know how to
> verify that.  So, I think I get that message either because the daemon
> is not running or that I don't have PulseAudio configured correctly.
> The first question is, then, how do I tell if the PulseAudio daemon is
> running?
>
> The second question comes from configuring PulseAudio.  The PulseAudio
> configuration page at
>
> http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/PerfectSetup/
>
> Says that for a system like mine in which udev and ConsoleKit give
> access to the sound card but override it with the "audio" group, should
> make sure no users are in the "audio" group.  It says that "fast
> switching" won't occur with people in the "audio" group.  This is a big
> deviation from what the book says during the installation of ALSA.  I
> don't like deviating from the book without bringing it to the list.  I
> can do it, but what are the pros and cons?
I removed myself from the audio group and still have access to the sound 
card as an unprivileged user. Although in my work with hdajackretask, I 
got asked for my password twice. I guess all is working as it should.

I apologize for going on and on about this stuff, but from the results, 
it's important to those whose systems use snd_hda_intel and have Beats 
Audio.

Dan





More information about the blfs-support mailing list