[blfs-support] CUPS and Mavericks

Pol Vangheluwe pol.vangheluwe at belgacom.net
Tue Dec 24 08:50:57 PST 2013


Op 11-nov.-2013, om 03:35 heeft Ken Moffat <zarniwhoop at ntlworld.com> het volgende geschreven:

> (…)
> Obviously, back up ALL of /etc/cups, the cups user programs [ cancel,
> cups*, lp*, pp* ], the cups /usr/sbin programs [ accept, cups*, lp*,
> reject ], /usr/lib/cups, /usr/lib/libcups*, /usr/share/cups,
> /usr/share/cups together with the programs from ghostscript if
> installed [ dumphint, dvi2pdf, eps2eps, font2c, gs*, lprsetup.sh,
> pdf*, pdf*, pf*, pp*, printafm, ps*, unix-lpr.sh, wftopfa ],
> /usr/share/ghostscript-v.wx  and if you use gutenprint, everything
> from that.
> 
> I've only ever used cups for printing from the same machine (I plug
> the printer in to whichever desktop box I'm using).  And I haven't
> needed to upgrade my printing stack recently, but my upgrade script
> deletes - /etc/cups, /usr/lib/cups, /usr/lib/libcups*,
> /usr/lib/gutenprint*, /usr/share/cups, /usr/share/gutenprint,
> /var/spool/cups.  I only use gutenprint, other printers might be a
> bit different, but you're using an Epson Stylus so I guess you too
> are using gutenprint.  A little of gs (at least, with the old cups
> versions) and gutenprint get installed into the cups directories.
> 
> I did once try not ripping everything out for a partial upgrade, but
> I ended up with a broken mix of versions.
> 
> I then rebuild the print stack - cups, [ for LFS-7.0+ I would
> update the cups bootscript for any potential improvements in newer
> versions, but you need to stick with the old bootscript - best to
> back that up too, just in case ], ghostscript (actually, current
> cups with gutenprint no longer needs gs but definitely reinstall if
> you use it), qpdf, cups-filters, gutenprint.  I see that I also
> reinstall ImageMagick, probably that links to the shared gs lib if
> both are installed.
> 
> I did build whatever versions were current for LFS-7.4 on ppc
> userspace [ G5 but using linux32 ] without any issues, but using an
> *old* toolchain might be different. I had a problem on x86_64
> LFS-7.0 (gcc-4.6.1) when I built firefox-25, but at least the error
> message suggested the workaround - in that case, add -fpermissive to
> the CFLAGS.  Usually, it is newer toolchains that give the grief.
> 
> But first - one of the other threads (about a similar problem using
> a NAS box running a binary old version of cups) had some success
> reports for an upgrade - looks like something was changed, but it was
> apparently still some sort of 1.4 version, so maybe just a config
> switch was involved, or a patch.  But one reporter said he had to
> add the printer again in osx.  And that is where things get murky -
> http://wiki.phys.ethz.ch/readme/printing_with_lpr_macos_x says that
> apple have changed how printers are added, and that you will need to
> use the LPD protocol [ see the note at the bottom of that page - up
> to 10.7 you could use cups ].  OTOH, a different site talks about
> using cups with 10.7/8/9.
> 
> I _think_ I would try installing current cups and its post-install
> deps [ it's a bit different since 1.6 ].  But that's only because no
> useful information about how they broke things seems to be out there.
> 
> Good luck, I hope you manage to fix it (and don't break the other
> osx machine's printing in the process).
> 
> ĸen
> -- 
> das eine Mal als Tragödie, dieses Mal als Farce
> -- 
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page

Trying to upgrade CUPS to release 1.6.3, as explained in the BLFS book (on a LFS-6.8 system …) + hints from Ken.
Found that the link to the patch doesn’t work.  Should be http://www.linuxfromscratch.org/patches/blfs/7.4/cups-1.6.3-blfs-1.patch
( so “7.4” instead of “svn”)
SVN already points to release 1.7.0.

pvg




More information about the blfs-support mailing list