[blfs-support] Problems compiling proftpd

Niels Terp nielsterp at comhem.se
Sun Mar 3 11:27:54 PST 2013


Hi,

 

I have just finished LFS 7.3 with a very good result, and now I want to
continue with BLFS.

 

I have already installed Open-SSH, wget and Apache webserver, which all
works well.

 

But I'm having a hard time compiling proftpd: According to the book, it
should be build as a non-priviledged user. I ran the first part as per the
book as root, then I logged in as a normal user, and try to make - but I got
a "permission denied" error.

 

I have also tried, despite the warnings (and after all, for now it is only
me who has access to the network). When I compile as root, the compilation
finishes without error, but when I reboot I get the following errors:

 

Starting FTP Server .[    11.797793] warning: 'proftpd' uses 32-bit
capabilities (legacy support in use)

lfs proftpd[1682]: warning: unable to determine IP address of 'lfs'

lfs proftpd [1682]: error: no valid servers configured

lfs proftpd[1682]: Fatal: error processing configuration file
'/etc/proftpd.conf'

[ FAIL ] *****

 

The .conf file is made straight from the book.

 

Can anybody help ?

 

Niels

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20130303/19fc837a/attachment.html>


More information about the blfs-support mailing list