[blfs-support] Python Modules

Simon Geard delgarde at ihug.co.nz
Wed Mar 6 02:15:34 PST 2013


On Wed, 2013-03-06 at 01:02 +0100, Jean-Philippe MENGUAL wrote:
> Hi,
> 
> Does someone have some experience about compatibility between the Python Modules
> and Python2.7 / 3.3? In my case, pyrex doesn't seem to install with Python3.3.
> Is it a known problem? Are a lot of modules incompatible with Python3.3?
> Actually, can Python3.3 be used alone, or both Python2.7 and 3.3 need to be
> present on the system for most modules?

There's no general answer to that question - it depends a lot on the
specific module. Some have separate versions for 2 vs 3 - others have
one version that can support either. But in the latter case, the
installation is usually specific to the Python version - you can't just
install it once, and have it used by both 2 and 3 (you have to install
two copies, even if it's the same source package).

And yes, a lot of modules still don't support Python 3 at all.

Simon.




More information about the blfs-support mailing list