[blfs-support] Abiword-2.9.3 fails to build without GTK+-3

Arthur Radley misterarthurradley at gmail.com
Mon Mar 11 09:07:53 PDT 2013


On 03/11/2013 12:24 AM, Arthur Radley wrote:
> Just FYI, mostly...
>
> Abiword-2.9.3 in the current BLFS svn version failed to build without
> GTK+-3 which is not listed as a required package in the book.
>
>  From the failed build...
>
> ---------------------------------------------
> configure: error: Package requirements (
>    fribidi >= 0.10.4
>    glib-2.0 >= 2.6.0 gthread-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0
>    libgsf-1 >= 1.12
>    wv-1.0 >= 1.2.0
>    enchant >= 1.2.0 gio-2.0
>    cairo-pdf cairo-ps pangocairo
>    gtk+-3.0 >= 3.0.8 gtk+-unix-print-3.0 librsvg-2.0 >= 2.16.0 cairo-fc
>   x11) were not met:
>
> No package 'gtk+-3.0' found
> No package 'gtk+-unix-print-3.0' found
> ---------------------------------------------
>
> I restored a tarball from an earlier point in the project and installed
> GTK+-3 alongside the existing GTK+-2. I also decided to install GOffice
> upgraded from v0.8.17 to to v0.10.0 since GTK+-3 was now present.
> Abiword-2.9.3 then installed normally, but it looked terrible (blacked
> out page rulers, blacked out highlighted text, black page borders, for
> example). That stuff was not unheard of on the Internet from back last
> summer. I uninstalled Abiword-2.9.3 and installed Abiword-2.9.4 which
> sort of fixed the rulers & borders. I then could see the rulers and tabs
> which seemed to work okay, but they looked kind of graphically crude.
> Both of these new Abiwords also ignored the normal.awt file in my home
> directory.
>
> Maybe people who install Gnome or KDE have some widget or other that I
> don't have and none of this happens to them. I have no way to know. In
> the end, I had no patience for any of this and restored again to my
> non-GTK+-3 BLFS project and continued on with it and the old
> Abiword-2.8.6 again. It's been working (and looks) fine. I'm almost
> finished with the project without needing GTK+-3 anyway.
>
> Just thought somebody might want to know that Abiword may be busted now.

I finally got Abiword-2.9.4 installed without GTK+-3 by using the 
--with-gtk2 configure option. That idea did not work with Abiword-2.9.3 
(make errors). With that option, Abiword-2.9.4 installed quietly, looks 
normal, and works normally. It still ignores normal.awt in $HOME, so I 
edited the system version of the file. This should get me and Abiword 
through the next six months or so.

Anyway, I don't know if any of this has any value for the book or not. 
But I followed the steps and commands in the current book for 
Abiword-2.9.3 but substituted Abiword-2.9.4, added --with-gtk2, and 
edited /usr/share/abiword-2.9/templates/normal.awt for the default font.

A. Radley





More information about the blfs-support mailing list