[blfs-support] ntp depends on libcap2 when use "-u" option.

xinglp xinglp at gmail.com
Mon Mar 11 20:11:31 PDT 2013


2013/3/12 Bruce Dubbs <bruce.dubbs at gmail.com>:
> Ken Moffat wrote:
>> On Mon, Mar 11, 2013 at 10:01:55PM +0800, xinglp wrote:
>>> BTW: Where can I get the information of a package is need by others
>>> and vice-versa in some other distro.
>>
>>   For gentoo (and, apparently, some other distros), google for ebuild
>> files - the dependencies part is usually understandable.
>>
>>   For fedora, http://pkgs.fedoraproject.org/cgit/ and use the search
>> field, then pick an appropriate branch (usually master), pick a
>> commit (usually the latest), go to 'tree' view, find the
>> packagename.spec file and open in 'plain' view.
>>
>>   For arch https://www.archlinux.org/packages/ - when you have
>> clicked on the package, under 'Package Actions' click 'Source Files'
>> and then look at the PKGBUILD.
>>
>>   Please remember that while a distro may need to make a package
>> depend on many things (and may split the package, and therefore need
>> to use -dev versions to be able to compile), not all of them will be
>> useful for an individual builder.
>>
>>   Or just look at
>> http://www.linuxfromscratch.org/blfs/view/svn/introduction/beyond.html
>> ;-)
>
> Another source is Debian.  The package lists give dependencies.  See,
> for instance, http://packages.debian.org/sid/xorg.
Thanks for you guys, I will report when I find dependency issue of the
packages that I'm in using.
>
>    -- Bruce
> --
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page



More information about the blfs-support mailing list