[blfs-support] Test of at-spi2-core-2.6.3 fails - Problem in D-Bus ?

Niels Terp nielsterp at comhem.se
Fri Mar 15 08:20:57 PDT 2013


Hi,

When I test at-spi2-core-2.6.3, I get the error:

process 19874: arguments to dbus_bus_get_unique_name() were incorrect, assertion "connection != NULL" failed in file dbus-bus.c line 813.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
/bin/sh: line 5: 19874 Afbrudt (SIGABRT)       ${dir}$tst
FAIL: dbtest
===============================================================
1 of 1 test failed
Please report to accessibility-atspi at lists.linux-foundation.org
===============================================================
make[2]: *** [check-TESTS] Fejl 1
make[2]: Forlader katalog '/home/niels/xc/at-spi2-core-2.6.3/dbind'
make[1]: *** [check-am] Fejl 2
make[1]: Forlader katalog '/home/niels/xc/at-spi2-core-2.6.3/dbind'
make: *** [check-recursive] Fejl 1

I have ALL the dependencies installed.

I have tried to recompile dbus, to no avail. Also tried to run the tests of dbus, which ends in an error message about missing Python modules - which completes the circle: I am compiling at-spi2-core as part of installing Python modules.

How should I move on ? Can I ignore the D-Bus error, or is it important ? If so, how can I compile D-Bus with -rdynamic (I don't find it in ./configure --help) ?

Niels




More information about the blfs-support mailing list