[blfs-support] Can not compile Kdelibs-4.10.1

Niels Terp nielsterp at comhem.se
Sat Mar 16 06:22:05 PDT 2013


Hi,

During the initial cmake step I get:

-- No backend for KAuth was explicitly specified: probing system to find the
best one available
-- Found PolkitQt-1: /lib/cmake/PolkitQt-1/PolkitQt-1Config.cmake (Required
is at least version "0.99.0")
-- Building PolkitQt-1 KAuth backend
CMake Error at kdecore/auth/ConfigureChecks.cmake:138 (string):
  string sub-command REPLACE requires at least four arguments.
Call Stack (most recent call first):
  kdecore/CMakeLists.txt:38 (include)

The cmake continues, prints some additional packages that would be
beneficial but not needed - and then it stops with:

-- Configuring incomplete, errors occurred!

It looks to me as the problem is in Polkit, I have tried to recompile, but I
still get this error. Any sugestions how to proceed ?

Niels




More information about the blfs-support mailing list