[blfs-support] Problem when building WebkitGTK with GTK+-2.34.16

Armin K. krejzi at email.com
Sun Mar 17 07:20:54 PDT 2013


On 03/17/2013 03:19 PM, Armin K. wrote:
> On 03/07/2013 02:47 AM, 901 STT wrote:
>> Hi,
>>
>> I have some problems when building WebkitGTK with GTK+-2.34.16. It
>> appears compiling GTKVersioning.c error that requires GdkDevice, with
>> not exist in GTK+2, it only exists in GTK+3. I added the line
>> "/|--with-gtk=2.0 --disable-webkit2|/" in configure to make sure but
>> still got that error. Log:
>>
>>    CC     Source/WebCore/platform/gtk/libWebCoreGtk_la-GtkVersioning.lo
>> In file included from Source/WebCore/platform/gtk/GtkVersioning.c:27:0:
>> /usr/include/gtk-2.0/gdk/gdkx.h:114:0: warning: "GDK_WINDOW_XWINDOW"
>> redefined [enabled by default]
>> In file included from Source/WebCore/platform/gtk/GtkVersioning.c:21:0:
>> Source/WebCore/platform/gtk/GtkVersioning.h:34:0: note: this is the
>> location of the previous definition
>> Source/WebCore/platform/gtk/GtkVersioning.c: In function
>> ‘getDefaultGDKPointerDevice’:
>> Source/WebCore/platform/gtk/GtkVersioning.c:60:5: error: unknown type
>> name ‘GdkDeviceManager’
>> Source/WebCore/platform/gtk/GtkVersioning.c:60:5: warning: implicit
>> declaration of function ‘gdk_display_get_device_manager’
>> [-Wimplicit-function-declaration]
>> Source/WebCore/platform/gtk/GtkVersioning.c:60:34: warning:
>> initialization makes pointer from integer without a cast [enabled by
>> default]
>> Source/WebCore/platform/gtk/GtkVersioning.c:61:5: warning: implicit
>> declaration of function ‘gdk_device_manager_get_client_pointer’
>> [-Wimplicit-function-declaration]
>> Source/WebCore/platform/gtk/GtkVersioning.c:61:5: warning: return makes
>> pointer from integer without a cast [enabled by default]
>> make[1]: ***
>> [Source/WebCore/platform/gtk/libWebCoreGtk_la-GtkVersioning.lo] Error 1
>>
>> Thanks for your feedback,
>>
>> Regards
>>
>> Duc Tran
>>
>>
>
> I can't confirm with WebKitGTK+ 1.10.2 and GTK+ 2.24.16. I did however
> had similar problem with WebKitGTK+ 1.11.90 and GTK+ 2.24.16 when I
> tried unstable GNOME build.
>

Also, I removed --with-gstreamer=1.0 switch ... Now it reminds me, 
WebKitGTK+ 1.11.90 has GStreamer 1.0 enabled by default - that could be 
reason why it fails.



More information about the blfs-support mailing list