[blfs-support] cups-filter-1.0.30 compilation error

Armin K. krejzi at email.com
Mon Mar 18 13:58:37 PDT 2013


Dana 18.3.2013 21:30, Sebastien Fievet je napisao:
> Hi all,
>
> I have troubles building cups-filter-1.0.30 following BLFS SVN Version 2013-03-16 steps.
> Compilation fails with the following error message :
> "filter/pdftoopvp/oprs/OPRS.cxx:30:22: fatal error: goo/gmem.h : No such file or directory"
>
> After a lot of digging and googling, I found out that this file is part of poppler source tree, but
> is not installed during poppler installation process.
>
> I satisfy all the dependencies but lcms which is 1.19 on my system and not 2.x, and avahi
> which I don't want to install, and configure runs fine as follows :
>
> ./configure --prefix=/opt --disable-static --disable-avahi --without-rcdir --with-pdftops=pdftops
>
> I found a thread from November 2012 on the same subject but it didn't help : the requestor
> gave up fixing it. I am stuck :-(
>
> I have :
> LFS-7.0
> poppler-0.22.2
> cups-1.6.1
> Qpdf-4.0.1
> lcms-1.19
> IJS-0.35
>
> Thanks for your help,
> Seb.
>

Well, you can't use LCMS 1.19 instead of 2.4 or whichever is in the book 
- they are different libraries. As for error, follow the book - don't 
modify the damn path, that's why you get the error. File your setup is 
missing is installed by Poppler.



More information about the blfs-support mailing list