[blfs-support] Missing cursor in text (console) mode

alex lupu alupu01 at gmail.com
Tue Mar 19 10:59:55 PDT 2013


Hi Bruce:

- Bruce:
What I have is
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y

If they are not set, then /dev/fb0 does not show up.
What happens for me is that the kernel dialog starts
and at about 0.5 seconds shifts into frambuffer mode.
I don't know how to prevent it if those options are
set, but you can control it by putting something like video=1366x768 on
the kernel command line (that's my monitor resolution).

- Alex:
I had CONFIG_FRAMEBUFFER_CONSOLE=m.  Made it y.
Great minds:  1366x768 is my preferred resolution too.

Still NO CIGAR.

- Bruce:
Now I'm not sure if the above are the only kernel issues.

 Bruce                                        Alex original
---------------------------------             -------------
CONFIG_FB_VESA=y                                NO
CONFIG_VIDEO_OUTPUT_CONTROL=y                   m
CONFIG_FB=y                                     same
# CONFIG_FIRMWARE_EDID is not set               y
# CONFIG_FB_DDC is not set                      same
CONFIG_FB_BOOT_VESA_SUPPORT=y                   NO
CONFIG_FB_CFB_FILLRECT=y                        m
CONFIG_FB_CFB_COPYAREA=y                        m
CONFIG_FB_CFB_IMAGEBLIT=y                       m

has /dev/fb0 but the one that has

# CONFIG_FB_BOOT_VESA_SUPPORT is not set

does not have /dev/fb0.

- Alex:
I brought all the above CONFIGs in line with yours but
still NO CIGAR.

- Bruce:
In any case, I'd suggest trying to disable the switch to graphical mode
during boot (if it's not already disabled) and see if that makes a
difference.

- Alex:
Which is the switch to graphical mode,
 "Enable modesetting on intel by default"?

Lost cause.  I've survived other indignities in life
(sacrifices are sometimes necessary for human progress).

Thank you very much,
-- Alex



More information about the blfs-support mailing list