[blfs-support] mpg123 Failed to open module alsa: file not found

Armin K. krejzi at email.com
Wed Mar 20 07:21:12 PDT 2013


On 03/20/2013 03:18 PM, Sven Bartscher wrote:
> I installed mpg123 and alsa-lib now i want to hear music and type the
> command:
> $ mpg123 <some cool tune>.mp3
> i get the following error:
> [module.c:142] error: Failed to open module alsa: file not found
> [module.c:142] error: Failed to open module oss: file not found
> [audio.c:180] error: Unable to find a working output module in this
> list: alsa,oss
> [audio.c:532] error: Failed to open audio output module
> [mpg123.c:897] error: Failed to initialize output, goodbye.
> i already googled for this problem and found a lot of people who had the
> same problem, but the solutions never worked for me.
> So i already tried:
> do the same command as root
> export LD_LIBRARY_PATH=/usr/lib:/usr/lib/mpg123 (maybe on this solution
> i did something wrong)
> i experimented a little bit on my own and tried to compile it with the
> option --with-module-suffix=.so but i get the same error.
> i hope someone can help me
> with hopefull regards
> Sven
>

You don't need LD_LIBRARY_PATH set to /usr/lib/mpg123 ... If you remove 
.la files, then --with-module-suffix=.so should suffice, given that 
/usr/lib/mpg123/output_alsa.so exists. Also, be sure to remove old 
versions of library if you are upgrading.



More information about the blfs-support mailing list