[blfs-support] ICU

Armin K. krejzi at email.com
Fri Mar 22 01:19:49 PDT 2013


On 03/22/2013 08:50 AM, Nicholas McCurdy wrote:
> I'm getting a compile failure while running make on ICU.
>
> I have tried the version in BLFS (ICU-50.1.2) and also ICU-50.1.1 with
> the same result, so I feel like my environment isn't set up perfectly.
>
> Though ICU has no explicit Dependencies, I have several packages
> installed into my successful LFS build with no unexpected failures to
> date...
>
> The error is as follows:
> make[2]: Leaving directory '/sources/icu/source/data'
> Unpacking ./in/icudt501.dat and generating out.tmp/icudata.lst (list of
> data files)
> LD_LIBRARY_PATH=../lib:../stubdata:../tools/ctestfw:$LD_LIBRARY_PATH
>   ../bin/icupkg -d ./out/build/icudt50l --list -x \* ./in/icudt50l.dat
> -o out/tmp/icudata.lst
> make[1]: *** [out/tmp/icudata.lst] illegal instruction
> make[1]: Leaving directory '/sources/icu/source/data'
> make: *** [all-recursive] Error 2
>
> I'm confused by the "illegal instruction"...  as straightforward as the
> message is, I'm not sure where to look to fix it.
> Any help is appreciated.
>
>
> Nicholas McCurdy
> mindwarpstudios at aim.com
>
>

I never saw that. Did you modify CFLAGS/CXXFLAGS for your packages?

Also, side note - next time write in plain text, your font is sometimes 
way too small to read.



More information about the blfs-support mailing list