[blfs-support] Autofs problem on LFS7.2

akhiezer lfs65 at cruziero.com
Mon Mar 25 12:43:47 PDT 2013


> Date: Mon, 25 Mar 2013 16:17:33 +0000
> From: lfs65 at cruziero.com (akhiezer)
> To: BLFS Support List <blfs-support at linuxfromscratch.org>
> Subject: Re: [blfs-support] Autofs problem on LFS7.2
>
	.
	.
> > > > 
> > > > Can you stop/kill the currently-running automount process, and verify via ps or 
> > > > similar that there's no automount processes running, and then run automount 
> > > > manually and in debug mode at console via:
> > > > 
> > > > $ automount -v -f -d 
> > >
> > > $ Without '-d'
> > > Starting automounter version 5.0.7, master map auto.master
> > > using kernel protocol version 5.02
> > > open_mount:244: parse(sun): cannot open mount module nfs 
> > > (//lib/autofs/mount_nfs.so: undefined symbol: auth_put)
> > > lookup(file): failed to open parse context
> > > lookup(file): file map /etc/auto_master missing or not readable
> > > no mounts in table
> > >
> > > Hangs at this point
> > > $
> > >
> > > $ With '-d'
> > > Starting automounter version 5.0.7, master map auto.master
> > > using kernel protocol version 5.02
> > > lookup_nss_read_master: reading master files auto.master
> > > parse_init: parse(sun): init gathered global options: (null)
> > > open_mount:244: parse(sun): cannot open mount module nfs 
> > > (//lib/autofs/mount_nfs.so: undefined symbol: auth_put)
> > > lookup(file): failed to open parse context
> > > lookup_nss_read_master: auto.master not found, replacing '.' with '_'
> > > lookup(file): file map /etc/auto_master missing or not readable
> > > no mounts in table
> > >
> > > Hangs at this point
> > > $
> >


A web search on the 'mount_nfs.so: undefined symbol: auth_put' turned up the 
bug-report and fix:

	https://bugs.mageia.org/show_bug.cgi?id=6903

The fix is basically to revert a change that was made going from version 5.0.6 
(which is what is running here) and 5.0.7 (which is what you've got). The above 
url links to the following page that shows the change:

	ftp://ftp.kernel.org/pub/linux/daemons/autofs/v5/patches-5.0.7/autofs-5.0.6-fix-libtirpc-name-clash.patch

So to revert the change, one would edit the file 'lib/rpc_subs.c' in the source 
distrib, and comment-out the code:
---
#ifdef WITH_LIBTIRPC
#undef auth_destroy
#define auth_destroy(auth)                                              \
                do {                                                    \
                        int refs;                                       \
                        if ((refs = auth_put((auth))) == 0)             \
                                ((*((auth)->ah_ops->ah_destroy))(auth));\
                } while (0)
#endif
---
thus (am not assuming you don't already know some/all of this kind of stuff):
===
/*
#ifdef WITH_LIBTIRPC
#undef auth_destroy
#define auth_destroy(auth)                                              \
                do {                                                    \
                        int refs;                                       \
                        if ((refs = auth_put((auth))) == 0)             \
                                ((*((auth)->ah_ops->ah_destroy))(auth));\
                } while (0)
#endif
*/
===
; and do leave single blank line above and below (not required from a technical 
point of view).
Then recompile autofs like you did before, and see how it goes. If it all goes 
well then one would need to determine if there are any unwanted side-effects 
from commenting out that code.


However, before going this edit/recompile route, it would be good if you could 
do the few tests in the earlier email today and from last night, with the 
currently-installed autofs.



rgds,
akh





--



More information about the blfs-support mailing list