[blfs-support] Autofs problem on LFS7.2

akhiezer lfs65 at cruziero.com
Mon Mar 25 15:37:28 PDT 2013


> Date: Mon, 25 Mar 2013 18:14:23 -0400
> From: "Cliff McDiarmid" <cliffhanger at gardener.com>
> To: "akhiezer" <lfs65 at cruziero.com>,
>         "BLFS Support List"
> 	<blfs-support at linuxfromscratch.org>
> Subject: Re: [blfs-support] Autofs problem on LFS7.2
>
	.
	.
> > >
> > > When you say 'it hangs': normally it'll not go back to the shell command prompt 
> > > but instead just sit waiting to output more diagnostics.
> > > What happens if you put in a usbstick and try to list its contents via 
> > > '\ls -laF /testautomount/sandisk' - do more diagnostic messages get printed? If 
> > > so, can you post them here, please? Thanks. If it seems that nothing is happening, 
> > > just wait for another minute or so.
>
> I only get the following again, but only after having to Ctr C to get out no activity after 10min
> $
> total 8
> drwxr-xr-x 2 root root 4096 Mar 23 09:38 ./
> drwxr-xr-x 3 root root 4096 Mar 23 09:38 ../
> $
>


Yes, if you ctrl-c to quit automount, then it's not running, and so you _would_ 
see an empty directory, because nothing's automounted there, because automount 
is not running, because it's just been ctrl-c quitted.


>
> $ Can you also run with specifying the master-map file explicitly:
> automount -v -f -d /etc/auto.master
> Starting automounter version 5.0.7, master map /etc/auto.master
> using kernel protocol version 5.02
> lookup_nss_read_master: reading master file /etc/auto.master
> parse_init: parse(sun): init gathered global options: (null)
> open_mount:244: parse(sun): cannot open mount module nfs 
> (//lib/autofs/mount_nfs.so: undefined symbol: auth_put)
> lookup(file): failed to open parse context
> no mounts in table
>
> This is with usbstick installed
> $
>


OK: it's just choking before parsing the master-map file. I'd go on and do the 
recompile approach, per earlier most-recent message today.


> $ grep -E 'N(F|I)S' /boot/config
> grep: /boot/config: No such file or directory
> $


Sorry, that should've been:
$ grep -E 'N(F|I)S' /boot/config*
$
Can you post that anyhow? Thanks.


> > > Did you use the same compile/install instructions for autofs as in the blfs book; 
> > > or adjust them at all? I guess you at least added the kernel config stuff for 
> > > AUTOFS4 . Did you install NFS: and if so any deviations from the book?
>
> Compiled autofs as in book. I was mistaken, did 'client-only'install of 
> OpenLDAP.  Did do install of Cyrus. Did not install NFS.
>  


OK. Will leave that info present here in case need to followup on it. But I'd 
go the recompile route from here.



rgds,
akh





--



More information about the blfs-support mailing list