[blfs-support] mpg123 Failed to open module alsa: file not found

svenbartscher at yahoo.de svenbartscher at yahoo.de
Sat Mar 30 04:56:13 PDT 2013


Nicholas McCurdy <mindwarpstudios at aim.com> wrote:

>
> >>On 03/20/2013 03:18 PM, Sven Bartscher wrote:
> >> I installed mpg123 and alsa-lib now i want to hear music and type the
> >> command:
> >> $ mpg123 <some cool tune>.mp3
> >> i get the following error:
> >> [module.c:142] error: Failed to open module alsa: file not found
> >> [module.c:142] error: Failed to open module oss: file not found
> >> [audio.c:180] error: Unable to find a working output module in this
> >> list: alsa,oss
> >> [audio.c:532] error: Failed to open audio output module
> >> [mpg123.c:897] error: Failed to initialize output, goodbye.
> >> i already googled for this problem and found a lot of people who had the
> >> same problem, but the solutions never worked for me.
> >> So i already tried:
> >> do the same command as root
> >> export LD_LIBRARY_PATH=/usr/lib:/usr/lib/mpg123 (maybe on this solution
> >> i did something wrong)
> >> i experimented a little bit on my own and tried to compile it with the
> >> option --with-module-suffix=.so but i get the same error.
> >> i hope someone can help me
> >> with hopefull regards
> >> Sven
> >>
>
> >You don't need LD_LIBRARY_PATH set to /usr/lib/mpg123 ... If you remove 
> >.la files, then --with-module-suffix=.so should suffice, given that 
> >/usr/lib/mpg123/output_alsa.so exists. Also, be sure to remove old 
> >versions of library if you are upgrading.
>
> Have you successfully output audio via ALSA before with this system?
> If you have already done so, please disregard this message: I cannot claim enough knowledge of mpg123 to assist...
>
>
> BUT, If this is a first-time setup and you have not yet successfully had sound working, try this approach:
> It looks like ALSA doesn't understand your sound card.
> command: cat /proc/asound/cards
> That will show you the detected specs of your sound card if it's being detected properly
> command: aplay -l       (that's a lowercase L)
> That will show you if ALSA has a clue what's going on...  the following paragraph assumes ALSA doesn't get it.
>
>
> If the response includes: "file not found" then check your kernel configuration for how you selected the the firmware for your sound card (of course, if it's missing be sure to enable it).  If you originally chose to set up your sound firmware as a module but didn't create the soundcore.ko module, you must change the selection for the sound sub-system (one tree level above ALSA/OSS in menuconfig) to "yes: module" instead of "yes: built-in" and recompile.  Among others, this change will yield the module soundcore.ko and will satisfy the kernel help note that details successful use of the soundcard modules.
>
>
> If ALSA still cannot see the sound card following a reboot, you might need to recompile ALSA now that your kernel understands what modules it's working with.
>
>
>
>
> Nicholas McCurdy
> mindwarpstudios at aim.com
>
>
I tried aplay -l (because i never heard sound from that system) and got an error that the command "aplay" wasn't found. Do i miss some package that's wasn't listed as a depencie of mpg123?



More information about the blfs-support mailing list