[blfs-support] Wrong prompt and "file not found" with xterm - BLFS 7.6

rhubarbpieguy at gmail.com rhubarbpieguy at gmail.com
Tue Dec 16 14:40:30 PST 2014


My BLFS 7.6 xterm window displays the wrong prompt, doesn't recognize 
aliases, and doesn't allow sourcing scripts.  Its prompt is "sh-4.3" 
although I have PS1="/w >" in /etc/bashrc.  Aliases don't execute and 
attempting to source a script results in "file not found."

However, if I exclude the "*VT100*locale: true" line in 
/etc/X11/app-defaults/XTerm" all problems disappear.  With that one 
change I have the correct prompt, can use aliases, and source scripts.  
Although that fixes the problem, it still doesn't explain my error to me.

Everything else works quite well but I'm curious as to what I'm doing 
wrong regarding X/xterm.  I hadn't the problem prior to BLFS 7.5 and 
don't see what I'm doing differently.  Thoughts?

-------------------------------------------

Should vt100 not isolate the error, as background, I should mention I 
had the same problem with BLFS 7.5 and posted the problem:

http://www.linuxfromscratch.org/pipermail/blfs-support/2014-April/074751.html

The thread explains what's been covered.  I received several good 
responses but no success.  I decided to let it go as I installed rxvt as 
a workaround and figured I wouldn't make the same mistake with the next 
release.  However, I underestimated my capacity for mistakes as I'm 
apparently quite well capable of making the same error in consecutive 
releases.



More information about the blfs-support mailing list