[blfs-support] Phonon-backend-vlc-0.7.1 DOES NOT COMPILE

Bruce Dubbs bruce.dubbs at gmail.com
Mon Mar 10 21:12:12 PDT 2014


me at pc-networking-services.com wrote:
> Hello,
>
> when trying to install phonon-backend-vlc by what is PUBLISHED in the book:

> -- Found LibVLCcore library path:/usr/lib/libvlccore.so
> -- Found LibVLC version: 2.1.3 (searched for: 0.0)
> -- Building against Phonon 4.2 API
> CMake Error at src/CMakeLists.txt:78 (qt5_use_modules):
>    Unknown CMake command "qt5_use_modules".
>
> What needs to be done to fix this error?

I didn't test with Qt5.  Are you on a 32-bit system?

If using Qt4 you should have:

-- Found Qt4: /opt/qt/bin/qmake (found suitable version "4.8.5", minimum 
required is "4.6.0")
-- Using CMake automoc builtin
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found Phonon: /opt/qt/lib/cmake/phonon
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.28")
-- checking for module 'libvlc'
--   found libvlc, version 2.1.3
-- Found LibVLC include-dir path: /usr/include
-- Found LibVLC library path:/usr/lib64/libvlc.so
-- Found LibVLCcore library path:/usr/lib64/libvlccore.so
-- Found LibVLC version: 2.1.3 (searched for: 0.0)
-- Building against Phonon 4.7 API
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these 
packages.
+ Qt4
+ Phonon
+ LibVLC
Congratulations! All external packages have been found.

The reason I ask about architecture is that I have 
/usr/lib64/libvlccore.so and you have /usr/lib/libvlccore.so.

   -- Bruce



More information about the blfs-support mailing list