[blfs-support] Iced Tea again!!!!!

me at pc-networking-services.com me at pc-networking-services.com
Sun Mar 23 02:15:18 PDT 2014


> On Sun, Mar 23, 2014 at 01:01:18PM +1300, me at pc-networking-services.com
> wrote:
>> Hello,
>>
>> Well this is ridiculous.  I have reached the point after a few days of
>> installing the systemd 7.5 version of LFS, and going through the
>> configuration of quite a number of other packages following BLFS 7.5
>> stable to the point of having a working graphical interface, so decide
>> now
>> is a good time to install java again.
>>
>> I set everything up as per the instructions, which I did when I first
>> set
>> it up following the previous version of LFS.
>>
>> This time round though I can NOT even get the blasted thing to compile.
>> I
>> have even reverted back to the iced tea 2.4.1 and get EXACTLY the same
>> message.
>>
>> Please note that in between changing the versions I have deleted the
>> files
>> for the CURRENT 7.5 stable version.  The only thing that I did not do
>> was
>> to delete /usr/share/java before extracting the earlier binary and
>> supporting files.
>>
>> BOOT_JAR_CMD = /opt/icedtea-2.4.1/bootstrap/jdk1.6.0/bin/jar
>>   BOOT_JARSIGNER_CMD =
>> /opt/icedtea-2.4.1/bootstrap/jdk1.6.0/bin/jarsigner
>>   JAVAC_CMD =
>>   JAVAH_CMD =
>>   JAVADOC_CMD =
>>
>> Build Platform Settings:
>>   USER = root
>>   PLATFORM = linux
>>   ARCH = i586
>>   LIBARCH = i386
>>   ARCH_FAMILY = i586
>>   ARCH_DATA_MODEL = 32
>>   ARCHPROP = i386
>>   ALSA_VERSION = 1.0.27.2
>>   OS_VERSION = 3.13.3 [requires at least 2.6]
>>   OS_VARIANT_NAME = Linux From Scratch
>>   OS_VARIANT_VERSION = 7.5-systemd
>>   MB_OF_MEMORY = 1504
>>
>> GNU Make Settings:
>>   MAKE = /usr/bin/make
>>   MAKECMDGOALS = sanity
>>   MAKEFLAGS = w
>>   SHELL = /bin/sh
>>
>> Target Build Versions:
>>   JDK_VERSION = 1.7.0_40External File/Binary Locations:
>>   USRJDKINSTANCES_PATH = /opt/java
>>   BUILD_JDK_IMPORT_PATH =
>> /NOT-SET/re/jdk/1.7.0_40/promoted/latest/binaries
>>     ALT_BUILD_JDK_IMPORT_PATH =
>>   JDK_IMPORT_PATH = /opt/icedtea-2.4.1/bootstrap/jdk1.6.0
>>     ALT_JDK_IMPORT_PATH = /opt/icedtea-2.4.1/bootstrap/jdk1.6.0
>>   LANGTOOLS_DIST =
>>     ALT_LANGTOOLS_DIST =
>> /opt/icedtea-2.4.1/openjdk.build-boot/langtools/dist
>>   CORBA_DIST =
>>     ALT_CORBA_DIST = /opt/icedtea-2.4.1/openjdk.build-boot/corba/dist
>>   JAXP_DIST =
>>     ALT_JAXP_DIST = /opt/icedtea-2.4.1/openjdk.build-boot/jaxp/dist
>>   JAXWS_DIST =
>>     ALT_JAXWS_DIST = /opt/icedtea-2.4.1/openjdk.build-boot/jaxws/dist
>>   HOTSPOT_DOCS_IMPORT_PATH = /NO_DOCS_DIR
>>     ALT_HOTSPOT_DOCS_IMPORT_PATH =
>>   HOTSPOT_IMPORT_PATH =
>> /opt/icedtea-2.4.1/openjdk.build-boot/hotspot/import
>>     ALT_HOTSPOT_IMPORT_PATH =
>> /opt/icedtea-2.4.1/openjdk.build-boot/hotspot/import
>>   HOTSPOT_CLIENT_PATH =
>> /opt/icedtea-2.4.1/openjdk.build-boot/hotspot/import/jre/lib/i386/client
>>     ALT_HOTSPOT_CLIENT_PATH =
>>   HOTSPOT_SERVER_PATH =
>> /opt/icedtea-2.4.1/openjdk.build-boot/hotspot/import/jre/lib/i386/server
>>     ALT_HOTSPOT_SERVER_PATH =
>>   CACERTS_FILE = ./../src/share/lib/security/cacerts
>>     ALT_CACERTS_FILE =
>>   CUPS_HEADERS_PATH = /usr/include
>>     ALT_CUPS_HEADERS_PATH =
>>
>> OpenJDK-specific settings:
>>   FREETYPE_HEADERS_PATH = /usr/include
>>     ALT_FREETYPE_HEADERS_PATH =
>>   FREETYPE_LIB_PATH = /usr/lib
>>     ALT_FREETYPE_LIB_PATH =
>>
>> Previous JDK Settings:
>>   PREVIOUS_RELEASE_PATH = USING-PREVIOUS_RELEASE_IMAGE
>>     ALT_PREVIOUS_RELEASE_PATH =
>>   PREVIOUS_JDK_VERSION = 1.6.0
>>     ALT_PREVIOUS_JDK_VERSION =
>>   PREVIOUS_JDK_FILE =
>>     ALT_PREVIOUS_JDK_FILE =
>>   PREVIOUS_JRE_FILE =
>>     ALT_PREVIOUS_JRE_FILE =
>>   PREVIOUS_RELEASE_IMAGE = /opt/icedtea-2.4.1/bootstrap/jdk1.6.0
>>     ALT_PREVIOUS_RELEASE_IMAGE =
>>
>>   MILESTONE = fcs
>>   RELEASE = 1.7.0_40-blfs
>>   FULL_VERSION = 1.7.0_40-blfs-b31
>>   BUILD_NUMBER = b31
>>
>> WARNING: This build does not include running javadoc.
>>
>> WARNING: The version of unzip being used is older than
>>        the required version of '5.12'.
>>        The version of unzip found was ''.
>>
>> WARNING: The version of zip being used is older than
>>        the required version of '2.2'.
>>        The version of zip found was ''.
>>
>> ERROR: The version of make being used is older than
>>        the required version of '3.81'.
>>        The version of make found was ''.
>>
>> ERROR: Your BOOTDIR environment variable does not point
>>        to a valid JDK for bootstrapping this build.
>>        A JDK 7  Update 40 build must be bootstrapped using
>>        JDK 1.6.0 fcs (or later).
>>        Apparently, your bootstrap JDK is version
>>        Please update your ALT_BOOTDIR setting and start your build
>> again.
>>
>> Exiting because of the above error(s).
>>
>> make/sanity-rules.gmk:71: recipe for target 'post-sanity' failed
>> make[1]: *** [post-sanity] Error 1
>> make[1]: Leaving directory '/opt/icedtea-2.4.1/openjdk-boot'
>> Makefile:2465: recipe for target 'stamps/icedtea-boot.stamp' failed
>> make: *** [stamps/icedtea-boot.stamp] Error 2
>>
>> I went to the icedtea wiki page at:
>>
>> http://icedtea.classpath.org/wiki/CommonIssues
>>
>> and it has the exact message about the ALT_BOOTDIR and it suggested
>> recompiling gcc.
>>
>> I have done this as I needed to add the other languages, so I did the
>> recompile of gcc stock standard per the BLFS book enabling all of the
>> languages, ran the test suite and tried the java build again with the
>> same
>> error.
>>
>> Could someone please help me with this as I really do not know what to
>> do
>> next.
>>
>> Regards,
>>
>> Christopher.
>>
>
>  I'm not particularly familiar with java at the moment, but I've
> built icedtea-2.4.2 twice - once in October/November, in a general
> test, once on 7.5 because I overlooked that the old version was
> invoked from the script :-( and I then built 2.4.5 on 7.5.
>
>  I've now looked at my last 2.4.2 log, and I see the sort of
> information you have posted above, just over 4000 lines into the
> build.  In your case, I am worried by the warnings about unzip and
> zip, and baffled by the error that 'make' seems not to have been
> found.  And after one Error, I think all bets for subsequent
> messages are off, in the same way that in a compilation failure we
> have to look at the first error.  I assume you haven't run out of
> disk space, or filled up /tmp ?  Rebuilding gcc seems an extreme
> suggestion (unless someone intends using gcc's java to bootstrap
> icedtea), so I'm not exactly surprised that it didn't help.
> But just to be clear : you can still build both C and C++ packages ?
>
>  For me, the pain of scripting java was in working out what to add
> to the builder's (for me, that is the big guy, whose username begins
>  with 'r') PATH - and, of course, remembering to set up my own PATH
> when I actually had to try to use java.  Is it possible that you
> screwed up something in that area ?  I find it hard to believe that
> you could have _lost_ the normal PATH (which would account for the
> zip, unzip, make messages), because at least in 2.4.2 the first part
> of the build looks to be a conventional configure which would crap
> out if /usr/bin was no longer in the PATH.
>
>  The only other things I might query are whether you correctly
> installed the binary openjdk, and whether you applied all the
> icedtea patches ?  Oh, and you ought to re-download the current
> version, because it was a vulnerability fix.
>
>  In my own script for building icedtea, I set the following before I
> try to build the BLFS-7.5 version:
> export JAVA_HOME=/opt/OpenJDK-1.7.0.51-bin
> export ANT_HOME=/opt/ant
> export CLASSPATH=/usr/share/java:/usr/share/java/junit-4.11
> export PATH="$PATH:/opt/OpenJDK-1.7.0.51-bin/bin:/opt/ant/bin"
>
>  I will hazard a guess that ANT_HOME has not yet come into play when
> your build fails, but the other parts - with whichever version of
> the OpenJDK bin you have installed - need to be set appropriately.
>
> ĸen
> --
> das eine Mal als Tragödie, dieses Mal als Farce
> --
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page


Hello,

Just to clarify things, I am able to build all the languages in the gcc
package without any issue.

Thank you for the suggestions so far, but things are still not working.

I have re-compiled gcc again as a check and enabled all languages.

After this I went through and followed the PUBLISHED instructions for
installing the binary version of openjdk and after setting the correct
paths I still received the same error.

It seems that setting the JAVA_HOME prior to the compilation of iced tea
is a bit of a waste of time as the build instructions are:

unset JAVA_HOME                                               &&
./autogen.sh                                                  &&
./configure --with-jdk-home=/opt/OpenJDK-1.7.0.51-bin         \
            --with-version-suffix=BLFS                        \
            --enable-nss                                      \
            --disable-system-kerberos                         \
            --with-parallel-jobs=$(getconf _NPROCESSORS_ONLN) &&
make

Which means that any variable set within JAVA_HOME is unset as soon as you
begin the compile process.

I have checked with the BLFS 7.4 instructions and the same thing is stated
there, and I WAS able to eventually successfully compile that version.

I need to state again that I am using the SYSTEMD version of LFS to build
this on, so I am not sure if SYSTEMD does things differently.

I have noticed in the compiling of iced tea that the block above that I
had not posted here complains about ZIP_VER BOOT_VER UNZIP_VER being
empty,

There is no .pc file created for zip unzip and possibly even make.

Is it possible to disable sanity checking in the compile to see if it is
that which is causing the compile to abort early?

I have tried looking through the Makefile for unzip and I can not work out
where to put version information.  It has a version specified for solaris
but seems to lack that for linux.

At this point I do not know what to do other than reformat the hard drive
yet again and come up with the exact same errors again.

When people are TESTING the versions of the book before making them a
release I am having a very hard time believing that what they are doing to
compile the package and what they have written that they have done are the
exact same things.  If they were, then someone such as me who is following
through the written instructions and copying and pasting them exactly
would be able to make it work from a bare hard drive.  This is clearly not
the case.

Below is the block that sanity checking is complaining about.  Could it be
as simple as re-compiling zip, unzip, and make with the missing
information, and or creating a .pc file for pkgconfig solve this?

Also is it possible that the developers of icedtea have changed their
scripts in between the time that this book was released and me going
through and trying to get it to work?


INFO: ENABLE_FULL_DEBUG_SYMBOLS=1
INFO: /usr/bin/objcopy cmd found so will create .debuginfo files.
INFO: STRIP_POLICY=no_strip
INFO: ZIP_DEBUGINFO_FILES=1
/bin/sh: line 0: [: too many arguments
/bin/sh: line 0: [: too many arguments
/bin/sh: line 0: [: too many arguments
/bin/sh: /bin/head: No such file or directory
/bin/sh: /bin/head: No such file or directory
/bin/sh: /bin/head: No such file or directory
/bin/sh: /bin/head: No such file or directory
/opt/icedtea-2.4.5/openjdk-boot/jdk/make/common/shared/Sanity-Settings.gmk:72:
WARNING: BOOT_VER should not be empty [Sanity-Settings.gmk]
/opt/icedtea-2.4.5/openjdk-boot/jdk/make/common/shared/Sanity-Settings.gmk:119:
WARNING: ZIP_VER should not be empty [Sanity-Settings.gmk]
/opt/icedtea-2.4.5/openjdk-boot/jdk/make/common/shared/Sanity-Settings.gmk:120:
WARNING: UNZIP_VER should not be empty [Sanity-Settings.gmk]
/opt/icedtea-2.4.5/openjdk-boot/jdk/make/common/shared/Sanity-Settings.gmk:200:
WARNING: MAKE_VER should not be empty [Sanity-Settings.gmk]
INFO: ENABLE_FULL_DEBUG_SYMBOLS=1
INFO: /usr/bin/objcopy cmd found so will create .debuginfo files.
INFO: STRIP_POLICY=no_strip
INFO: ZIP_DEBUGINFO_FILES=1
make[2]: Leaving directory '/opt/icedtea-2.4.5/openjdk-boot/jdk/make'


Regards,

Christopher




More information about the blfs-support mailing list