[blfs-support] LFS/BLFS system displays a kernel version of my host system not displays it's own kernel version

akhiezer lfs65 at cruziero.com
Tue Nov 18 08:15:27 PST 2014


> Date: Mon, 17 Nov 2014 20:45:46 +0800
> From: Sainadh J <jsainadh at ymail.com>
> To: BLFS Support List <blfs-support at lists.linuxfromscratch.org>
> Subject: Re: [blfs-support] LFS/BLFS system displays a kernel version of my
> 	host system not displays it's own kernel version
>
> Sainadh J wrote:
>
> >>> Hello, i build LFS/BLFS 7.6 system, when i run "uname -r" it's
> >>> displays my host system kernel version(3.10.17),but my kernel version
> >>> is 3.16.2 i don't know why i getting my host system kernel version on
> >>> my LFS/BLFS system.please help me friends.Thanks in advacne.
> >>
> >>> You booted a 3.10.17 kernel that you either built or was already on your
> >>> system.  Check the linux command line in grub.cfg.
> >>
> >>> You might want to check the directories in /lib/modules to see what the
> >>> system has.
>
> >> i attached my grub.cfg file.i found 3.16.2 directory in /lib/modules
> > but i found there broken symlinks i.e build and source,i think this
> > could be cause a reason my system displays a host kernel version i don't
> > know clearly please guide me how to solve this issue.Thanks in advance.
> >
> >> The symlinks are not needed unless you are installing proprietary
> >> drivers for something like nvidia or vmware.
> >
> >> grub.cfg looks OK, but is grub looking at the grub.cfg for the original
> >> host?  At the grub prompt, select e to see if the linux
>  line is what you
> >> have in your attachment.
> >
> >> What is the output of 'dmesg|head|grep Linux'.  In my case I have:
> >
> >> [    0.000000] Linux version 3.16.2-lfs76rc1 (root at toshiba-lfs) (gcc
> >> version 4.9.1 (GCC) ) #1 SMP Mon Sep 8 22:53:24 CDT 2014
>
> > i didn't find grub folder on my host which is "/boot".the output of
> "dmesg|head|grep Linux"root
>  [ / ]# dmesg|head|grep Linux
>
> > [    0.000000] Linux version 3.10.17 (root at hive64) (gcc version 4.8.2 (GCC) )
> #2 SMP Wed Oct 23 16:34:38 CDT 2013
> > root [ / ]#
>
> > the same output i getting when i run host system also.
>
> >I think grub is looking at a different location for grub.cfg.  Did you run
>
> >grub-install /dev/sda
>
>
>    >-- Bruce
> >Hello Bruce,
>
> >i run "grub-install /dev/sda" on my host system which gives a following output:
>
> >grub-install
>  /dev/sda
> >/usr/sbin/grub-bios-setup: warning: Sector 32 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its >authors not to store data in the boot track.
> >/usr/sbin/grub-bios-setup: warning: Sector 33 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its >authors not to store data in the boot track.
> >Installation finished. No error reported.
>
> >I can't find any drivers in "/lib/modules/3.16.2/kernel/drivers" expect net drivers only.
>
> >now also i can't find "grub.cfg" on "/boot/grub".i found few directories and one file
>  on /boot/gurb/ such as "fonts,1386-pc,locale,gurbenv file.
>
>
> Hello,
>
> my problem causing i am using LILO As my boot loader.today i added my LFS/BLFS boot image to the Slackware grub2 after i restart my system and select my LFS/BLFS boot image after i run the "uname -r" it succesfully displays my kernel version i.e 3.16.2.and i solved another problem i think you remember it "my mouse and keyboard didn't work on xorg windows"why beacause i do not add my LFS boot image to the grub2 package so my kernel not loaded correctly so that i am facing problems with my input devices.today my previous issues also solved.Thanks for trying to help to me.


 - per:

http://www.linuxquestions.org/questions/slackware-14/my-new-lfs-system-displays-a-my-host-system-slackware-kernel-version-4175525555/

(?)


akh





--


More information about the blfs-support mailing list