[blfs-support] configure error in httpd-2.4.16 Book 7.8

Ken Moffat zarniwhoop at ntlworld.com
Thu Mar 3 17:28:26 PST 2016


On Thu, Mar 03, 2016 at 05:52:56PM -0600, Arnie Stender wrote:
> Hello,
>     I am plodding along with my new BLFS 7.8 build and Apache was an
> optional for whatever it was I wanted to build so I figured I'd do it now.
> When I ran the configure I got the following:
> 
> checking for APR... configure: error: the --with-apr parameter is incorrect.
> It must specify an install prefix, a build directory, or an apr-config file.
> 
> The book included the following as an argument for configure:
> 
>   --with-apr=/usr/bin/apr-1-config
> 
> I don't know what it is looking for. A name of a file it is supposed to
> create? An existing file it is supposed to run? It doesn't like the "1" in
> the filename it got? What is the work around or fix? I didn't see anything
> in wiki. Thanks in advance.
> 
> Arnie

Arnie,

let me ask a different question: where did you install apr-1-config
?

If you are still puzzled, please follow the dependency chain for
apache and make sure you install both apr packages.

ĸen
-- 
This email was written using 100% recycled letters.


More information about the blfs-support mailing list