[blfs-support] compilation error in Kde-workspace-4.11.21

Bruce Dubbs bruce.dubbs at gmail.com
Thu Mar 10 19:45:01 PST 2016


Dr.-Ing. Edgar Alwers wrote:
> On Sun, 6 Mar 2016 18:45:00 +0000 Ken Moffat <zarniwhoop at ntlworld.com>
> wrote:
>
>> I finally gave up because I was told that mariadb (default for
>> akonadi - I failed to persuade it to use sqlite) needed to be
>> compiled _before_ qt4 : when I tried to rebuild qt4, it failed
>> (details in the thread).
>
> Hi Ken,
>
> well. As I built qt-4.8.7 some days ago, I did  ./configure with
> "-plugin-sql-mysql", but this was not accepted, as I had not built
> MariaDB at that time. Now, I have MariaDB installed, but Akonadi, of
> course, is not working as it complains about a missing database driver
> ! So I went to rebuild qt4, with the addition  "-plugins-sql-mysql" in
> ./configure. To my astonishment, "make" crashes after more then 2 hours
> with a lot of complains about "»QWebPage« is not a Typ", "»WebAction«
> not declared" and so on. Cannot be true: I only add a plugin
> configuration, not rejected,  and the make process crashes ?
>
> I need to recompile qt4 if I want to use kmail and company. Can you
> help ?

I ran the instructions as printed adding -plugin-sql-mysql and it did not 
build for me.  Indications are that the -no-webkit option may have caused 
that.  I'm rerunning without -no-webkit, but have to go to class.  I'll 
tell you results in about 6 hours when I get back.

----

OK, I meant to send this 6 hours ago but didn't press 'Send'.  The rebuild 
was successful so if -plugin-sql-mysql is added, we must remove -no-webkit

   -- Bruce


More information about the blfs-support mailing list