[blfs-support] remote display

Arnie Stender astender777 at gmail.com
Sat Mar 12 10:11:08 PST 2016


On 03/10/2016 03:50 PM, Pol Vangheluwe wrote:
>> Op 10 mrt. 2016, om 21:06 heeft Arnie Stender <astender777 at gmail.com> het volgende geschreven:
>>
>> Hello,
>>    Back when I did this for a living I used to remotely display all kinds of X applications to my local desktop. I always thought that functionality was built into the X-Server. I can't seem to make it happen. I have a number of workstations connected to a KVM and I have my good keyboard connected to them. Now I have this new BLFS workstation I am building and I want to run all the build processes on that system but use my normal desktop and keyboard. I have killed the firewall, run xhost +, and have been trying to run firefox and xterm from the BLFS system and display the windows on my other desktop. All I get is errors. For example when I run 'xterm -display stender3:0' I get: "xterm: Xt error: Can't open display: stender3:0". Once again either something has changed or I am missing some simple but key factor. Seems to me I used to remotely display an entire desktop but that may have been when all I had was an X-terminal. When I tried that I got display in use errors. If anyone can point me in the right direction I would appreciate it. Thanks in advance. I didn't say it before but I killed the firewall and ran xhost + on stender3 where I expect to see the xterm pop up. From what I can find in man pages and on the web it looks like it should still be possible.
>> Arnie
>> -- 
>> http://lists.linuxfromscratch.org/listinfo/blfs-support
>> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
>> Unsubscribe: See the above information page
> So, you want to set up a connection from your desktop (the screen server) to your BLFS system (the screen client)?
> Did you allow X11 forwarding on your client?  Check with grep X11 /etc/ssh/sshd_config ~/.ssh/*grep
>
> Then connect with ssh -Y <your login>@<your client> and start an app.
> (this is the way I do with my iMac as server)
>
> pvg
>
OK, I think I am losing or maybe have lost my mind. A couple days ago 
Bruce gave me a long post with detailed instructions on how to work 
through my remote display problem. Some how, some way, I have managed to 
lost it before I got around to doing it. I have been up on the archive 
and have searched for the "remote display" subject. I see a number of 
posts from different people on a lot of different subjects from this 
month but not my posts or any of the reply posts from Bruce, Pol or 
anyone else. Is there a time delay before the posts go to archive?

Bruce, If you would be so kind, could you please resend that detailed 
set of instruction?

I sort of got pulled off of this problem for a while because for a while 
because of self inflicted problems my BLFS system became UN-bootable. I 
have that fixed now but have come up with a bunce of different questions 
which I will post with new threads. Thanks a bunch for being here.

Arnie



More information about the blfs-support mailing list