[blfs-support] LibreOffice's Python

Arnie Stender astender777 at gmail.com
Thu Mar 17 11:23:33 PDT 2016



On 03/17/16 13:13, Paul Rogers wrote:
> I built my 7.7 system with Python-2.7.9.  But now I want LibreOffice,
> which wants Python-3.  The book implies one can have both, but says
> nothing about "making that work".  Is there anything special I have to
> do so both continue to work without Python-3 nobbling -2?
Hi Paul,
     I just built office on my new 7.8 system. I have both Python 2 and 
Python 3 loaded. The only time I had a problem was that when I wanted to 
run Python 2 the binary I have to call is Python. If I want to run 
Python 3 the binary is python3. I was writing some scripts and didn't 
have the right binary in the opening line. IE "#!python3" I guess office 
knows which one it wants to talk with. :-)

Arnie


More information about the blfs-support mailing list