[lfs-support] LFS-BOOK-7.0 Section 5.9 binutils pass2 doubt

Andrew Benton andy at benton.eu.com
Tue Jun 19 11:23:12 PDT 2012


On Tue, 19 Jun 2012 18:09:21 +0100
Emerson Yesupatham <yemerson1976 at gmail.com> wrote:

> *My host system violates one of the prerequisites mentioned in page XVi*
> 
> *Linux Kernel-2.6.25 *

So what are you saying, that your kernel is older than 2.6.25?
Glibc is configured with --enable-kernel=2.6.25 so if you try to use it
(eg, when configuring the next package, Binutils) with an older kernel
it won't work and you'll get an error message like the one you posted.
The obvious solution is to get a newer kernel but you could also try
configuring glibc with --enable-kernel=$(uname -r) but it may not work
(I can't remember why).
So upgrade your kernel before you start the book.

Andy



More information about the lfs-support mailing list