[lfs-support] LFS 7.8 Section 5.20 (File-5.24) Compilation issue

Ken Moffat zarniwhoop at ntlworld.com
Mon Nov 9 11:54:13 PST 2015


On Mon, Nov 09, 2015 at 02:31:48PM +0000, Malik Benkirane wrote:
> > Your config.log suggests that you should not have the entry in
> > config.status
> 
> Actually I have an entry in my config.status : S["LIBS"]="-lz "
> 
> > but do you have the entry in your Makefile
> 
> Yes I do : at line 244 : LIBS = -lz
> 
> > Also, in config.h, is #define HAVE_LIBZ present (lines 78,79) ?
> 
> Yes it is : at line 79 : #define HAVE_LIBZ 1
> 
> Thank you and sorry for the time I took to answer your last Email Ken
> Moffat...
> 

Please don't top post.  Thanks.

The config.log you posted showed that it did NOT find zlib (if I
recall correctly, it looks for a header and does not find that).

Have you stopped the build, gone back into LFS and had another try
at building file ?  If so, I think you have somehow not set up the
environment correctly when you returned - configure should be
looking at what is in /tools.

This still doesn't make a lot of sense to me, because your earlier
answers sounded as if you were doing everything correctly, and yet
it still failed.  Hmm, did you (on the first attempt) run configure
and then either stop, shut down, and later resume before you tried
to run 'make' ?

ĸen
-- 
Il Porcupino Nil Sodomy Est! (if you will excuse my latatian)
  aka "The hedgehog song"


More information about the lfs-support mailing list