[lfs-support] file-5.28 make all-recursive error

Roger Frost frostrl at hotmail.com
Wed Jan 4 10:56:32 PST 2017


Greetings,

I'm at LFS version 7.10, section 6.12. File-5.28

In short, here is my problem:

package file:/usr/src/file/file-5.28> make
make  all-recursive
make[1]: Entering directory '/usr/src/file/file-5.28'
Making all in src
make[1]: *** [Makefile:399: all-recursive] Error 1
make[1]: Leaving directory '/usr/src/file/file-5.28'
make: *** [Makefile:331: all] Error 2

Deviations from the book:
1) I'm building a multilib LFS 7.10 system based (loosely) on CLFS Version 3.0.0-SYSVINIT-x86_64-Multilib.
2) I employ the Package Users method of package management.

(Yeah, I know... are you still with me?)

Host system:
Second generation multilib (B)LFS 7.7, also based on CLFS, also with Package Users.

Package configurations attempted (all produce the same result):
1) CC="gcc ${BUILD32}" ./configure --prefix=/usr (<=== this is the one I need to work)
2) CC="gcc ${BUILD64}" ./configure --prefix=/usr --libdir=/usr/lib64
3) ./configure --prefix=/usr
4) ./configure
5) ./configure --prefix=/usr --disable-zlib

Environment:
package file:/usr/src/file/file-5.28> env
HZ=100
CLFS_TARGET32=i686-pc-linux-gnu
SHELL=/bin/bash
TERM=xterm
OLDPWD=/usr/src/file
USER=file
BUILD64=-m64
BUILD32=-m32
MAIL=/var/spool/mail/file
PATH=/usr/lib/pkgusr:/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin
PWD=/usr/src/file/file-5.28
SHLVL=1
HOME=/usr/src/file
LOGNAME=file
PROMPT_COMMAND=PS1="package \u:"`pwd`"> "
_=/tools/bin/env

Other observations:
1) The error only happens at the top-level Makefile, (ie. I can './configure && cd src && make' successfully).
2) file-5.28 will build on my host system with no deviations from CLFS instructions.
3) Attempting to build as root instead of the Package User will fail in exactly the same way.
4) Attempting to build the old version from LFS 7.7 (file-5.22) in the chroot environment will fail in exactly the same way.
5) zlib (32-bit and 64-bit) built without a hitch after the toolchain was adjusted.
6) I'm not a Makefile debugger, I don't even play one on TV.

Bottom Line:
What could cause a top-level Makefile to fail in this way, yet still be able to 'make' in SUBDIRs?

Could I work around this? Probably, based on the fact that I can 'make' inside the src sub-directory. Do I want to? No, I need to figure out the cause, it's likely to be an ongoing problem if I don't.

If you have any questions, please ask! I've tried everything I can think of. I tried to include config.log, but evidently the message was too large (>100KB) and was rejected. I'll be happy to provide any output requested that may help track down the issue.

And finally, sorry if this is not the best list for this question, but the cross-lfs list appears to have died 5 years ago.

Thank you,
Roger

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20170104/bcf57b1a/attachment.html>


More information about the lfs-support mailing list