[lfs-support] LFS-8.2: 6.12. File-5.32

Baho Utot baho-utot at columbus.rr.com
Tue Jul 3 15:07:32 PDT 2018


On 07/03/2018 05:49 PM, Ken Moffat wrote:
> On Tue, Jul 03, 2018 at 05:17:27PM -0400, Baho Utot wrote:
>>> I think you answered a different question from the one I asked.  I
>>> don't care what worked in your 8.1 build, only whether all recent
>>> versions of file show the problem in your current build.
>>>
>>> And if they do, any other infromation you can gather will be useful.
>>>
>>> ĸen
>> I am using the version of file that is in the LFS-8.2 book
>>
> It feels as if you are deliberately misunderstanding what I ask.
> I'll reply to your other post.
>
Completely missing what you are saying.  I am using the the LFS-8.2 
handbook downloaded from the linuxfromscratch.org.  I am following the 
book using the versions AS OUTLINED in the handbook. Chapter 6.12 gives 
the version as file-5.52 and I have no idea as to why you think I am 
using anything else.   I have built the tool chain ( chapter 5) and then 
I am at this point in the build AGAIN following the LFS-8.2 handbook.

Anyway here is what I found:

I reran the the test from Chapter 6.10 and it gave this result

[Requesting program interpreter: /lib64/ld-linux-x86-64.so.2]

/lib64 is empty at this point in the build, so I proceeded with the 
following

cd /lib64
cp /lib/ld-2.27.so .
ln -sf ld-2.27.so ld-linux-x86-64.so.2

Now /lib64 has the "ld files"
the configure in chapter 6.12. File-5.32
/configure --prefix=/usr
will now complete.

My question now is what should be in /lib64 at this point?




More information about the lfs-support mailing list