[lfs-support] LFS 7.10 systemd - boot OK on SSD thunderbolt but fail with USB3

DOMINIQUE VAYSSAIRAT dovayssa at gmail.com
Wed Jul 4 10:52:48 PDT 2018


Hello Word,

Please, does someone have an idea for the problem below :

I built a lfs 7.10 / systemd machine on three stages :
	1 - on a virtual machine under virtualbox
	2 - many tries on a physical machine (which is a macbook pro) and using several different externals disks (SSD, SD cards) plugged on a USB ports
	3 - finally i get success with a SSD plugged on a thunderbolt port

First and third tries are OK/
Second trie end with a kernel panic each time.
I think that the problem is about USB because on the screen of the kernel panic I see that the kernel do not found the / partition.
I tried with boot=/dev/sda4 , boot=UUID=xxx and finally boot=PARTUUID=xxx with the same result

The third trie start correctly, the external disk used has two ports : USB-3 and Thunderbolt and one can use it in others circumstances alternatively  (either USB or Thunderbolt)
When i plug it with thunderbolt  ==> OK
Without any change plugging it with USB ==> kernel panic
The only-one différence is the cable and connected port.

All the kernel is compiled without module option but only with =y
 
Regards, Dominique 



More information about the lfs-support mailing list