[lfs-support] Booting LFS with systemd

Frans de Boer frans at fransdb.nl
Thu Jul 5 23:20:11 PDT 2018


On 07/05/2018 11:56 PM, Bruce Dubbs wrote:
> On 07/05/2018 02:48 PM, Frans de Boer wrote:
>> On 06/30/2018 01:29 PM, Hazel Russman wrote:
>>> On Fri, 29 Jun 2018 01:25:29 -0400
>>> Michael Shell <list1 at michaelshell.org> wrote:
>>>
>>>> On Thu, 28 Jun 2018 16:06:00 +0800
>>>> Xi Ruoyao <ryxi at stu.xidian.edu.cn> wrote:
>>>>
>>>>> Now I only use "initrd" directive to update CPU microcode and fix the
>>>>> buggy ACPI DSDT of my laptop (another sad story).
>>>>
>>>> .........
>>>>
>>>> And as there now seems to be several people who suffer with the
>>>> ACPI DSDT driver bug, you guys should make sure upstream is aware
>>>> of the problem, if they aren't already.
>>>>
>>> ...........
>>>>    Cheers,
>>>>
>>>>    Mike
>>>>
>>>> -- 
>>> I did a git bisect on my system, but I couldn't make much sense of 
>>> the result. The commit it finally settled on didn't seem to have 
>>> anything to with acpi.
>>>
>>> [quote]
>>> Bisecting: 2 revisions left to test after this (roughly 1 step)
>>> [9af9b94068fb1ea3206a700fc222075966fbef14] x86/cpu/AMD: Handle SME 
>>> reduction in physical address size
>>>
>>> Bisecting: 0 revisions left to test after this (roughly 1 step)
>>> [33c2b803edd13487518a2c7d5002d84d7e9c878f] x86/mm: Remove 
>>> phys_to_virt() usage in ioremap()
>>>
>>> Bisecting: 0 revisions left to test after this (roughly 0 steps)
>>> [7744ccdbc16f0ac4adae21b3678af93775b3a386] x86/mm: Add Secure Memory 
>>> Encryption (SME) support
>>> [unquote]
>>>
>>> I sent the result to the kernel acpi development list but never got 
>>> an answer. If someone else on this list wants to try, I can send him 
>>> my complete bisect logs.
>>>
>>> -- 
>>> Hazel
>> This quite frustrating. After recompiling, following the book to the 
>> letter, I still get a frozen LFS system.
>> One thing I do note however is that the freezing always occurs after 
>> systemd has detected that it is on a virtual machine. A number of 
>> error messages is send, but due to ratelimiting I can't see them 
>> because they are suppressed.
>>
>> I had even rebuild everything with systemd-232, and that worked as 
>> before. But after 232, things started to behave strange. Now way to 
>> debug systemd, whatever I do....
>>
>> Help?
>
> I don't mean to be pedantic, but I really don't think you would run 
> into these types of problems using System V.  Why not try that?
>
>   -- Bruce
>
Hi Bruce,
With System V there is - of course - no problem. The thing is that 
systemd - if it runs well - is somewhat easier to use because of the use 
of .service files. I also noticed that some packages are only shipping 
.service(.in) files and have abandon the use of sysVinit files. Combined 
with the fact that most distributions have embraced systemd as their 
primary or only init system let me believe that we are stuck with this 
piece of ever growing mutation. And as LFS is a teaching ground, it 
should - however reluctant - incorporated this too.

Also, the goal is that someone fire-up their basic hardware with a LFS 
born OS, but for testing or use in VM's development is nowadays mostly 
within the VM realm.

Regards,
Frans


More information about the lfs-support mailing list