<br><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Nov 12, 2012 at 5:11 PM, Yuan Cao <span dir="ltr"><<a href="mailto:yuancao85@gmail.com" target="_blank">yuancao85@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="gmail_extra"><div class="gmail_quote"><div><div class="h5"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">

Message: 5<br>
Date: Fri, 09 Nov 2012 16:02:54 -0600<br>
From: Bruce Dubbs <<a href="mailto:bruce.dubbs@gmail.com" target="_blank">bruce.dubbs@gmail.com</a>><br>
Subject: Re: [lfs-support] LFS 7.2 Section 6.4 Chroot Error<br>
To: LFS Support List <<a href="mailto:lfs-support@linuxfromscratch.org" target="_blank">lfs-support@linuxfromscratch.org</a>><br>
Message-ID: <<a href="mailto:509D7D8E.7080807@gmail.com" target="_blank">509D7D8E.7080807@gmail.com</a>><br>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed<br>
<br>
Yuan Cao wrote:<br>
> Hello,<br>
><br>
> I have an error when I tried to execute the first chroot script:<br>
><br>
> chroot "$LFS" /tools/bin/env -i \<br>
>      HOME=/root                  \<br>
>      TERM="$TERM"                \<br>
>      PS1='\u:\w\$ '              \<br>
>      PATH=/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin \<br>
>      /tools/bin/bash --login +h<br>
><br>
> When executing it, I encounters the following error:<br>
><br>
> chroot: failed to run command `/tools/bin/env': No such file or directory.<br>
><br>
> I have double checked the symlink of /tools and it still targets<br>
> /mnt/lfs/tools. I also looked over the instructions in 6.1 - 6.3, and I<br>
> could not find a mention on creating the /tools/bin/env directory.<br>
><br>
> Should I just use mkdir to create a /tools/bin/env directory, or am I<br>
> missing a step?<br>
<br>
You are missing a step.  /tools/bin/env is a binary, not a directory.<br>
Recheck your coreutils installation in Chapter 5.   Also, you said you<br>
checked the symlink, but let us know the output of:<br>
<br>
$ ls -l /tools<br>
$ ls -l /mnt/lfs/tools<br>
<br>
   -- Bruce<br>
<br></blockquote></div></div><div><br>Output for ls -l /tools & ls -l /mnt/lfs/tools:<br><br>lrwxrwxrwx 1 root root 14 Oct 23 16:04 /tools -> /mnt/lfs/tools<br>ls: cannot access /mnt/lfs/tools: No such file or directory<br>

<br>With ls -al /mnt/lfs:<br><br>drwxr-xr-x   5 root root 4096 Nov  9 12:44 .<br>drwxr-xr-x   4 root root 4096 Oct 26 10:12 ..<br>drwxr-xr-x  18 root root 4180 Nov  9 18:15 dev<br>dr-xr-xr-x 177 root root    0 Nov  9 09:34 proc<br>

drwxr-xr-x  13 root root    0 Nov  9 09:34 sys<br><br><br></div><div class="im"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
<br>
> chroot: failed to run command `/tools/bin/env': No such file or<br>
> directory.<br>
<br>
Do this:<br>
<br>
readelf -e /tools/bin/env | grep interpreter<br>
<br>
<br></blockquote></div><div>Output for that is:<br><br>readelf: Error: '/tools/bin/env': No such file.<br><br></div></div></div></blockquote><div>Hello,</div><div><br></div><div>I am still not sure how to solve this problem. Any advice is welcome.</div>
<div><br></div><div>I believe the above situation was caused by one or more steps from 5.34 or 6.2, since there is no instructions on having to do something in steps  6.0, 6.1 and 6.3. </div><div><br></div><div>I do have a backup copy of /mnt/lfs/tools and /mnt/lfs/source. Can I simply move them back into /mnt/lfs?</div>
<div><br></div><div>Best Regards,</div><div><br></div><div>Yuan Cao </div></div></div>