When I try to compile gcc from 5.5 I get this after running make:<br><br>checking for complex.h... yes<br>checking for library containing creal... -lm<br>checking whether creal, cimag and I can be used... yes<br>checking for an ANSI C-conforming const... yes<br>
checking for size_t... yes<br>checking for gettimeofday... yes<br>checking for localeconv... yes<br>checking for setlocale... yes<br>checking for dup... yes<br>checking for dup2... yes<br>checking for __gmpz_init in -lgmp... yes<br>
checking for MPFR... no<br>configure: error: libmpfr not found or uses a different ABI (including static vs shared).<br>make[1]: *** [configure-mpc] Error 1<br>make[1]: Leaving directory `/mnt/lfs/src/gcc-build'<br>make: *** [all] Error 2<br>
<br>the output of the version check script is:<br><br>bash, version 4.2.24(1)-release<br>/bin/sh -> /bin/dash<br>Binutils: (GNU Binutils for Ubuntu) 2.22<br>bison (GNU Bison) 2.5<br>/usr/bin/yacc -> /usr/bin/bison.yacc<br>
bzip2,  Version 1.0.6, 6-Sept-2010.<br>Coreutils:  8.13<br>diff (GNU diffutils) 3.2<br>find (GNU findutils) 4.4.2<br>GNU Awk 3.1.8<br>/usr/bin/awk -> /usr/bin/gawk<br>gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3<br>(Ubuntu EGLIBC 2.15-0ubuntu10.3) 2.15<br>
grep (GNU grep) 2.10<br>gzip 1.4<br>Linux version 3.7.0-030700-generic (root@gomeisa) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #201212102335 SMP Tue Dec 11 04:36:24 UTC 2012<br>m4 (GNU M4) 1.4.16<br>GNU Make 3.81<br>
patch 2.6.1<br>Perl version='5.14.2';<br>GNU sed version 4.2.1<br>tar (GNU tar) 1.26<br>version-check.sh: line 30: makeinfo: command not found<br>Texinfo: <br>xz (XZ Utils) 5.1.0alpha<br>gcc compilation OK<br><br>
im running ubuntu 12.04 and i have not deviated from the book<br><br><br>