<div dir="ltr"><div class="gmail_extra"><br></div><div class="gmail_extra"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<div dir="ltr">You should be chrooted into your new LFS build before installing the headers at step 6.7.1. As such your version of bash should look "similar" to this:<br><div>bash -version<br>GNU bash, version 4.2.45(2)-release (x86_64-unknown-linux-gnu)<br>
</div></div></blockquote><div><br></div><div>My bash version is:</div><div>root:/sources# bash -version</div><div>GNU bash, version 4.2.45(2)-release (i686-pc-linux-gnu)</div><div><br></div><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<div class="im">
<br>
</div>If command substitution is broken in your temp tools bash while in<br>
chroot, then your host wasn't setup properly. You should have bash as<br>
your default shell and bison yacc, not some other yacc. The host<br>
system requirements page helps set the stage for that.<br><div class=""><div class="h5"><br></div></div></blockquote><div><br></div><div>My linux distribution is Debian 7.1 and 'Berkley LA LR Yacc parser generator' is installed by default. I should change it to 'YACC-compatible parser generator' and rebuild bash in tools.</div>
<div><br></div><div>Thank you, gentlemen. </div><div><br></div><div>--</div><div>With respect,</div><div>Artem Orlov</div></div><br></div></div>