[links-list] Patch: SSL revisited (patch cleanup)

thristian at atdot.org thristian at atdot.org
Mon Aug 28 18:43:32 PDT 2000


On Mon, Aug 28, 2000 at 04:45:39PM -0400, Bennett Todd wrote:
> 2000-08-28-17:20:42 Morten Bo Johansen:
> > It almost completed - but only almost. The process comes to a
> > halt with a a longish outburst of errors of which I'm only
> > including a few:
> >[...]
> > Any idea what the problem is this time? 

Oddly enough, I'm getting exactly the same error. It gets all sorts of
undefined references to SSL functions, despite having -lssl -lcrypto
and an appropriate -L parameter.

> You didn't include quite enough, I don't think.
> 
> But I'd guess it'd be a problem with not finding the right OpenSSL
> stuff.
> 
> Do you:
> 
> - have a recent OpenSSL installed? (I use 0.9.5a)

I've got 0.9.5, but w3m compiled against it just fine.

> - have it installed with libs in /usr/lib/lib{crypt,ssl}* and
>   headers in /usr/include/openssl/*

I have libs in /home/users/timallen/lib, and headers in
/home/users/timallen/include/openssl. I changed your
-I/usr/include/openssl to -I/home/users/timallen/include/openssl, and
I changed LDFLAGS to -L/home/users/timallen/lib -lcrypto -lssl, and
removed -lcrypto -lssl from LIBS. Still doesn't work. *sigh*.

> - have matching versions of the headers and the libs

Should work...

> If so, please email me the full output from the command sequence
> 
> 	gzip -d <links-0.92.tar.gz|tar xvf -
> 	patch -p1 -d links-0.92 <links-0.92-ssl.patch
> 	cd links-0.92
> 	./configure
> 	make

I applied it directly on top of the results of the previous Basic-WWW
Authenticaion patch, and there was one near-miss (one patch was
applied 18 lines offset) and one conflict (stamp-h) which didn't seem
too important.

In case it's useful, the log starts with:

gcc  -g -O2 -L/home/users/timallen/lib -lcrypto -lssl -o links
https.o af_unix.o beos.o bfu.o bookmarks.o cache.o charsets.o
connect.o cookies.o default.o dns.o error.o file.o finger.o ftp.o
html.o html_r.o html_tbl.o http.o kbd.o language.o mailto.o main.o
menu.o os_dep.o sched.o select.o session.o terminal.o types.o url.o
view.o win32.o  -lgpm
https.o: In function `ssl_init':
/staff2/home/timallen/download/links-0.92/https.c:9: undefined
reference to `OpenSSL_add_all_algorithms'
/staff2/home/timallen/download/links-0.92/https.c:10: undefined
reference to `SSL_load_error_strings'
/staff2/home/timallen/download/links-0.92/https.c:11: undefined
reference to `SSLv23_client_method'

...and finishes with:

sched.o: In function `del_connection':
/staff2/home/timallen/download/links-0.92/sched.c:224: undefined
reference to `SSL_free'
/staff2/home/timallen/download/links-0.92/sched.c:228: undefined
reference to `SSL_CTX_free'
collect2: ld returned 1 exit status
make: *** [links] Error 1


There's more in the middle, but it's much the same stuff.

The last time I tried this, I was getting undefined references inside
the SSL library itself...

-- 
,------------------------------------------------- ------ ---- -- -  -   -
| Screwtape | Reply-To: is munged on Usenet | members.xoom.com/thristian
|--------------------------------------------- ---- ---- --- -- - - -  -  
|
| "We've got a lot in common" "I've always thought so, too." -- M*A*S*H
|

---------------------------------------------------------------------
To unsubscribe, e-mail: links-unsubscribe at appwatch.com
For additional commands, e-mail: links-help at appwatch.com
Visit AppWatch at http://appwatch.com for the latest apps




More information about the links-list mailing list